GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

Transmission wont shift

Discussion in 'Chevy Truck Talk & GM News' started by lifted71, Nov 30, 2011.

  1. lifted71

    lifted71 New Member

    Joined:
    Nov 30, 2011
    Messages:
    12
    Likes Received:
    0
    In my 94 z71 my transmission wont shift ive changed the fluids and the filter and it still wont shift but the only way it will shift is if i let off the throttle and then push back on it? Does any one know what i need to do to fix this problem?
    #1
  2. ChevyFan

    ChevyFan Administrator Staff Member

    Joined:
    Dec 1, 2004
    Messages:
    5,002
    Likes Received:
    13
    Lets see what we're dealing with first.

    Miles, engine & tranny type, history of issues, how long a problem, etc?
    #2
  3. lifted71

    lifted71 New Member

    Joined:
    Nov 30, 2011
    Messages:
    12
    Likes Received:
    0
    its got 118,000 on it its got a 4L60E and i bought it this summer but i talked to the guy and he said it shifted perfect when i bought it and it shifted fine when i got the motor in it but about 2 weeks after i got it running it started doin it.
    #3
  4. silveradotrailblazer

    silveradotrailblazer New Member

    Joined:
    Dec 23, 2008
    Messages:
    7,291
    Likes Received:
    20
    Welcome to the club. Try some Lucas oil trans fix. It helps free up sticking valves in the trans. Its cheap and worth a try. Also when you changed the fluid and filter was there anything in the pan and what did the fluid look like?
    #4
  5. billnorman

    billnorman New Member

    Joined:
    Jul 21, 2011
    Messages:
    196
    Likes Received:
    0
    I don't know diddly about transmissions, but I think the engine control computer factors engine speed and vehicle speed VSS together to control shifting. If you get it to shift letting off the gas, maybe there is a vacuum input on your computer that is receiving or sending a bad signal too.
    #5
  6. lifted71

    lifted71 New Member

    Joined:
    Nov 30, 2011
    Messages:
    12
    Likes Received:
    0
    i havent tried lucus but i did change the fluid and filter nd it didnt have anything in the pan
    #6
  7. dipstick

    dipstick New Member

    Joined:
    Dec 8, 2011
    Messages:
    308
    Likes Received:
    3
    You put a motor in the truck? Has the service light come on or abs light. Usually if it is vss /vehicle speed sensor will get a abs light....or any of these
    Vss abs.. tps/throttle position sensor ..map... drac... brake switch..speedo.. pcm.. are tied to the transmission.
    Check the harness to trans. good for breakage bare spot. Can you manually shift through gears? Is speedo bouncing/ erratic?
    Last edited: Dec 14, 2011
    #7
  8. lifted71

    lifted71 New Member

    Joined:
    Nov 30, 2011
    Messages:
    12
    Likes Received:
    0
    yeah and the check engine lights on and cant manually shift it and the mass airflow sensor is all messed up
    #8
  9. dipstick

    dipstick New Member

    Joined:
    Dec 8, 2011
    Messages:
    308
    Likes Received:
    3
    Yeah to what ..on the speedo? What engine do you have in the 94? 94 had 4.3 vortec with maf/ mass air flow. If it is a 5.7 /350 no maf.or 5.0/305
    Is abs/antilock light on? Need to scan for codes. should be a link here how to check codes.. if not look up my posts will find one with info.
    codes are great will narrow problems down. I could tell you how to check vss.. and all might still have to .
    So scan keep things simpler. If you do have a maf need to replace or clean.. make sure all down stream of maf is sealed tight.
    Need to fix this first will cause all sorts of symptoms.

    ---------- Post added at 03:06 PM ---------- Previous post was at 03:04 PM ----------

    www.obd-codes.com/faq/read-gm-2-digit-obd-codes-free.php here this will help.
    #9
  10. johnb9173

    johnb9173 New Member

    Joined:
    Dec 5, 2011
    Messages:
    14
    Likes Received:
    0
    They put a 4.3 in a 94 Z71? Never saw one of Those.
    #10
  11. lifted71

    lifted71 New Member

    Joined:
    Nov 30, 2011
    Messages:
    12
    Likes Received:
    0
    it has a 5.7 tbi nd yes it has a mass and thats the only thing that came up
    #11
  12. dipstick

    dipstick New Member

    Joined:
    Dec 8, 2011
    Messages:
    308
    Likes Received:
    3
    No what i,am saying he put a engine in the truck a 94.. 96 and up has maf sensors ..was asking what engine did he install
    If he did put a 94 4.3 has to be a vortec with a maf. We have to read whole threads he said he put a 4.3 in a z71 with a maf all messed up.

    ---------- Post added at 01:05 PM ---------- Previous post was at 12:55 PM ----------

    If it is a tbi.. it does not have a maf sensor. When you say tbi.. throttle body injection..are there two injectors on throttle body?
    Or just a throttle body.. for air intake only. Is there a plenum /cover over the intake?How are you scanning for codes obd1 or obd11?
    Vortec obd11 .tbi obd1 If it has a maf code ..and you have one ..will be a sensor beside. in front of air filter housing tube from air filter will go to throttle body. Clean or change it first.
    #12
  13. dipstick

    dipstick New Member

    Joined:
    Dec 8, 2011
    Messages:
    308
    Likes Received:
    3
    Does engine idle high?
    #13
  14. lifted71

    lifted71 New Member

    Joined:
    Nov 30, 2011
    Messages:
    12
    Likes Received:
    0
    it would idle at low rpms nd its tbi and it came out of a 94 chevy astro nd wont have to worry about it anymore she is sold as of tomorrow
    #14

Share This Page