Trouble codes when regearing

Discussion in 'GM Powertrain' started by 05bluebeauty, Mar 25, 2010.

  1. 05bluebeauty

    05bluebeauty New Member

    Here is the problem i am having, Hopefully someone has had this problem and has a solution. I have a 6 inch lift on my truck with 35x12.5 tires and just got 4.56 gear. Everything works great and i love the setup, but i am now getting my brake and abs lights on. also getting 3 troubles listed below. If anyone knows a solution please let me know

    c0035
    c0040
    c0245
  2. trouble codes whn regearing

    You need a programmer such as the Diablo Preditor to adjust the ecm for the new gear and tire size. You ecm is confused with the new changes because it was calibrated for the stock gears and tires. The Diablo also lets you tunethe engine and tranny.
  3. 05bluebeauty

    05bluebeauty New Member

    I have a hypertech programmer that is programmed to my 35's and 4.56s and still get the codes
  4. trouble codes whn regearing

    Try progamming back to stock and reinstall the Hypertech tune.
  5. 05bluebeauty

    05bluebeauty New Member

    Already did, still get codes
  6. trouble codes whn regearing

    Hope I dont offend you with this question but are you sure your entering the info correctly? Other than that I would call Hypertechs tech line.
  7. 05bluebeauty

    05bluebeauty New Member

    Yes i correctly entered all information as i am i very familiar with these tuners and working around trucks and cars. Have called hypertech and they give me nothing but the im sorry there is nothing we can do
  8. 05bluebeauty

    05bluebeauty New Member

    Just spoke with the 5th guy there and he said to lie to the computer and bring the tire size down and that might fix the problem
  9. trouble codes whn regearing

    Most 35x12.50s are about 34" tall not a true 35". Maybe try entering 34".
  10. 05bluebeauty

    05bluebeauty New Member

    Ya gonna try that and see if that works. i hate lights being on on my dash
  11. trouble codes whn regearing

    The only code your showing that I could fine in my manual is the c0245. It says EBCM control valve circuit, usually caused by an open or shorted solenoid coil in the EHCU. ?????? Maybe if you found a shop with a good scanner, like a Snap On it would tell you more.
  12. 05bluebeauty

    05bluebeauty New Member

    This all started as soon as i left the gear shop so im almost positive i dont have a short or anything like that anywhere. if this doesnt fix it then i guess ill have to take it somewhere because im sick of seeing those lights.
  13. dsfloyd

    dsfloyd New Member

    I know that the ABS light comes on with 4.56's. Not sure on the other codes. Superlift used to sell a calibration unit for that. Part#34000. I might call them and see if they still sell it as I didnt see it under accessories.
  14. 05bluebeauty

    05bluebeauty New Member

    Thanks for the input, im not sure if they still have it but i looked up the instructions off there website and that seems like it will work perfectly.
  15. dsfloyd

    dsfloyd New Member

    you may have seen this on their site but here is their number. 888) 299-4692.
    They are open until 5CST M-F. They should be able to help out.
  16. 05bluebeauty

    05bluebeauty New Member

Share This Page