GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

Trouble With Blower Motor 95 chevy 1500

Discussion in 'GM Electrical Tech' started by ThomG, Jun 19, 2011.

  1. ThomG

    ThomG New Member

    Joined:
    Jun 19, 2011
    Messages:
    3
    Likes Received:
    0
    What a headache, I replaced the blower motor, relay, resistor and the control assembly and have power at the blower motor (purple wire) using the ground wire and a test light the lower 3 settings have power and the high setting does not have power. The blower will not work on any setting. Tired of spending money with no result. Anyone have a suggestion?
    #1
  2. ThomG

    ThomG New Member

    Joined:
    Jun 19, 2011
    Messages:
    3
    Likes Received:
    0
    The problem has now spread to the wipers not working and the truck dies for no apparent reason, have to wait a few minuets to crank it back up. I think there's a short in the wiring somewhere. (pulls hair out) ..
    #2
  3. stephan

    stephan New Member

    Joined:
    Sep 28, 2010
    Messages:
    8,610
    Likes Received:
    14
    Since this seems to have spread to the wipers & the engine, I would check the batt to engine ground, chassis to engine/batt ground & the engine to body grounds.
    #3
  4. ThomG

    ThomG New Member

    Joined:
    Jun 19, 2011
    Messages:
    3
    Likes Received:
    0
    Thanks stephan, I should've mentioned that its the 6.5 TD and I just had the intake off to replace the fuel lines and wire wheeled the engine to battery ground on the driver side and another ground (small black wire) on the passenger side by the transmission dipstick tube. It all ran ok for a couple months except the AC blower motor problem. I replaced everything and still no blower. As I understand it the High setting does not pass through the resistor. Its not blowing any fuses and there's power all the way to the blower except on "High".. I do not know for sure if the other problems are related because the wipers haven't been used in a while because we have a drought here. The radio, dash lights, gauges and warning lights and everything else have good ground and no problems (so far). I'll look for other grounds and see.
    #4

Share This Page