1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Truck Almost Dies And Weird Things Happening Please Help Me

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by cappyd892, Jul 19, 2010.

  1. cappyd892

    cappyd892 New Member

    Ok well tonight i was driving my truck and as i was shifting through the gears, at about 30 MPH when it shifted, the RPMs went way down almost as if the truck was going to die. So i let off the gas and it went back to normal because it then shifted down. So I go to take back off and when it shifted up again it did the same thing. As I was driving i looked over and noticed the 4x4 light was on the 4 low. I didnt change this unless i accidentally hit it but im pretty sure i didnt. so i come to a stop and i push the 2wd buttom and it makes the noise as if it was going in but i go to take off and it switched but into 4 low and the light was still on 4 low. So i stopped again and it changed to 2wd this time when i pressed the button. It was just weird how the truck almost died when it shifted going down the road. Any ideas please let me know.

    Also the other night i was driving and all the gauges in my dash went to as if he truck was turned off and then all turned back on but the truck was never shut off and it was dinging but then went back to normal. I was driving the whole time. So idk what is going on. Thanks
  2. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    IS the Check Engine light on? That is for sure where i would start.
  3. Metaluzc

    Metaluzc Rockstar 4 Years 100 Posts

    Did you try pulling any codes for the truck or taking it to an auto parts store and having them hook it up to one of their diagnostic machines? Sounds like an electrical/fuse problem.
  4. cappyd892

    cappyd892 New Member

    The service engine light is not on. I haven't taken it anywhere yet. Just wanted to see if anybody had any idea what it could be
  5. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    I know this may sound simple but try tightening your battery cables. I've seen wierd elec. problems and it was just loose cables.
  6. cappyd892

    cappyd892 New Member

    ok ill try that as soon as i get home.. imma outta town for a few days. Also another strange thing iv seen it do a couple times is that while im driving the red neutral light will be on between the 2wd and 4hi buttons. I just push 2wd and the light would change but.
  7. trapperdon

    trapperdon Rockstar 100 Posts

    i take it that its electronic push button 4wd control module on the dash & NOT a shift lever on the floorboard?
    you have a short in you shift control, and possibly a bad signal being sent to the nuetral switch that is telling it
    to shift into 4 low...
    you need to get under your dash and start jiggling wires one at a time, one of em is loose.
    just hope that its one thats not under the rig on the transfer case where you cant get at it...

Share This Page