GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

truck will not run

Discussion in 'GM Electrical Tech' started by 97mud, Feb 6, 2013.

  1. 97mud

    97mud New Member

    Joined:
    Jan 29, 2013
    Messages:
    15
    Likes Received:
    0
    I have a 97 chevy k1500 5.7L 350
    im getting spark and fuel with no issues but it will not run i spray starter fluid in and it cranks over till all the starter fluid is gone then dies on me i need help
    i already replaced the fuel filter
    #1
  2. RayVoy

    RayVoy Active Member

    Joined:
    Apr 18, 2012
    Messages:
    2,122
    Likes Received:
    5
    If it runs with starter fluid, you are not getting fuel.

    Fuel pump relay, or the pump (can you hear the pump operate?)


    Edit: or, no fuel in tank.
    #2
  3. 97mud

    97mud New Member

    Joined:
    Jan 29, 2013
    Messages:
    15
    Likes Received:
    0
    yes its getting fuel to the fuel rail and its comes out the injecters i can smell it from the exhaust
    but will not run could it be that im not getting enouch psi?
    #3
  4. MrShorty

    MrShorty Moderator

    Joined:
    Jan 12, 2006
    Messages:
    1,368
    Likes Received:
    9
    I'm not sure it is fair to say "it is for sure getting fuel" until you've checked the fuel pressure. If you haven't yet put a fuel pressure gauge on it, then that is the next step.
    #4
  5. 97mud

    97mud New Member

    Joined:
    Jan 29, 2013
    Messages:
    15
    Likes Received:
    0
    the psi should be around 60 correct
    #5
  6. MrShorty

    MrShorty Moderator

    Joined:
    Jan 12, 2006
    Messages:
    1,368
    Likes Received:
    9
    published spec is 60-66 psi. When I had trouble with mine a few months ago, 45-50 appeared to be near the minimum needed to start.
    #6

Share This Page