1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

truck wont shift out of 2nd

Discussion in 'GM Powertrain' started by Sicksilverado781, Apr 3, 2010.

  1. Sicksilverado781

    Sicksilverado781 New Member

    so all of a sudden my truck wont shift out of 2nd i didnt hear any noises or anything.i dont really know much about transmissions so someone please help me.my truck is a 03 1500 5.3
  2. Sicksilverado781

    Sicksilverado781 New Member

    it has 125,xxx never had any problems with it.
  3. Sicksilverado781

    Sicksilverado781 New Member

    the service 4wd has come on a few times when it was really cold other than that i cant think of anything
  4. rustyk2

    rustyk2 Rockstar 4 Years 500 Posts

    Sounds like the problem I'm having, My 1988 drops third and will not go back. Jimmie is helping me, He is most learned in transmissions and their workings. My problem turned out to be a broken plastic piece under the valve body. Why GM uses plastic or composite for this stuff is beyond me. Check out my thread in this forum, it might be the same issue. Good Luck.

    Dana
  5. Sicksilverado781

    Sicksilverado781 New Member

    thanks for the help.mine didnt make any noises or anything it just all of a sudden stopped working
  6. rustyk2

    rustyk2 Rockstar 4 Years 500 Posts

    Mine made no noise, just dropped the gear.I posted a pic of what went wrong on my thread, page three. Also Jimmie was accurate in what went wrong.
  7. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    IS the CEL on?? Sounds like your tranny is in safe mode.
  8. Loggerhead Mike

    Loggerhead Mike Rockstar 100 Posts

    x2, we call it limp home mode

    could be a number of things. need to get the codes scanned and watch the tranny data
  9. Sicksilverado781

    Sicksilverado781 New Member

    thanks for the help
  10. AMC NUTZ

    AMC NUTZ New Member

    Could be a host of things... Ive had all of em on different veihicles. Does your speedo work? Does it start in first then lock in 2nd or always in 2nd? We call it limp mode. Check yours trans fluid and see if it is red/plum/rust/or black in color. does it have bubbles and appear copper in color when warm? Have you had any work done recently? are you getting any codes thrown? is the CEL on?

    Id be happy to point you in the right direction if you can answer some of these q's

Share This Page