Newest Gallery Photos

  1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Turn Signal Issue

Discussion in 'GM Electrical Tech' started by Crakums_GT, Sep 17, 2010.

  1. Crakums_GT

    Crakums_GT Epic Member 5+ Years 500 Posts

    A recent problem has presented itself with my 04 Silvy. When I turn on my left turn signal, both signals flash. Does anybody know what the problem could be before I start tearing things apart? Yesterday it stopped after I turned my hazards on and then off but today that didn't work for me. Thanks in advance...

    -Greg
     
  2. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Sounds like your turn signal unit is begining to go out. which isnt uncommon with these trucks.
     
  3. ThatSilverStepside

    ThatSilverStepside Rockstar 4 Years 100 Posts

    Mine was doing that for a bit, Did you just replace the bulbs? I was an idiot in a hurry at the parts store and grabbed the wrong bulbs...Not enough resistance I think? After I replaced them they started to blink at the same time, Got the right bulbs and it was fixed...Of course that was on a 1990 silverado, may not be the same for yours..Just a thought..
     
  4. Crakums_GT

    Crakums_GT Epic Member 5+ Years 500 Posts

    I haven't changed the bulbs recently. I can't decide what it is. It's happened a couple more times and if I turn the right signal on and then go back to the left signal it will usually fix itself. Also sometimes it will blink both signals once or twice but fix itself when I turn the wheel the slightest bit making me think it may be some sort of short in the steering column. I also read that it can sometimes be caused by the trailer lights adapter. Anybody heard of this?
     
  5. Irving10

    Irving10 New Member

    Greg (or anyone), what was the conclusion to this problem? I'm having the same issue with my '04 Silverado now. Thanks!!
     
  6. r_w

    r_w New Member

    Most likely the turn signal module. The replacements at Autozone and Advance are made by the original OE, most of the others are not...
     

Share This Page