Newest Gallery Photos

  1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Turn Signal problem.. doesn't pulse..

Discussion in 'General Chevy & GM Tech Questions' started by Falcone, Oct 29, 2009.

  1. Falcone

    Falcone Rockstar 100 Posts

    First off its a 92 sonoma reg cab short box 2.8L and well my left turn signal is messed up now. At first I thought it was just because the bulb was burnt out so I replaced that. Didn't cure it, checked the fuse, looks to be intact and fine. So now I got no no clue. The indicator has been slightly (broken) since I picked up the truck last year, meaning it won't self cancelle and just stays on even after I've completed my left turn. But now the bliner just lights up and stays on, it doesn't blink.. Any input guys?
     
  2. vncj96

    vncj96 Epic Member 5+ Years 1000 Posts

    pull the bulbs out of the taillight and check the actual socket, if it is brown or black inside it is fried.
     
  3. Falcone

    Falcone Rockstar 100 Posts

    the socket looked fine when I changed it, the bulb lights up, but it just doesn't flash for signaling.
     
  4. vncj96

    vncj96 Epic Member 5+ Years 1000 Posts

    Swap the bulbs just to double that its not another bad bulb.
     
  5. Loggerhead Mike

    Loggerhead Mike Rockstar 100 Posts

    sounds like your switch may be bad
     

Share This Page