Turning signal fuse blows

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by dasv001, Apr 26, 2009.

  1. dasv001

    dasv001 New Member

    I have just become a proud owner of a Suburban 4x4 diesel -99. Nice truck with few previous owners. There is one issue and the seller says it has been there since the truck was new. Can't believe that.

    Whenever the stick shift is placed in parking position, and the engine is running, the turning signal (blinker) fuse blows. How is this possible??

    As long as the stick shift is in any other position than parking, everything is fine regardless if the engine runs or not. In parking position, it's safe if the engine is off, but as soon as i start it up, the blinker fuse blows.

    I can't really imagine how these things are connected, but I have to find a solution. I might be the least experienced Suburban owner on this forum, so any suggestion would be of great help.

    Thanks.

    Dag
     
  2. r_w

    r_w New Member

    Dag, I'm a little confused, are you saying it is an automatic transmission, and when the column shifter is in Park and the vehicle is running this happens?
     
  3. vncj96

    vncj96 Epic Member 5+ Years 1000 Posts

    I would bet that when you put the gear selector into part it is pushing the wires around causing it to make contact with something metal or another wire and its popping, you probably have wire insulation cracked/exposed. From what I have read its not too hard to take the steering column off the dash, but cant help you exactly how to do it, I know there was recently a post about this thought, just have to search a little, if you do figure it out give us a write-up!
     

Share This Page

Newest Gallery Photos