1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Upgraded stereos

Discussion in 'Audio, Video & Gadget Tech' started by amd's chevy, Mar 24, 2009.

  1. amd's chevy

    amd's chevy New Member

    So after about a year of driving around with a blown speaker I finally upgraded my stereo in my truck. I also put a similar stereo in my car.

    In my truck I went with Alpine IDA-X100 deck. I use my ipod everywhere so it is perfect deck for me. (I have sony cd changer for anyone who wants to listen to a cd in it). I went with the Alpine MRP-F600 Amp, and 61/2 type R speakers in the front and 4x6 rears. They fit in perfectly which is what I wanted. The system sounds fantastic.

    In my '90 vette I put in Alpine IDA-X200 deck, Alpine PDX amp (fits in tight confines much better, plus doesn't get as hot), and focal speakers which fit in without modifications and are great sounding speakers for their size (4" in front and 6" in the rear).

    The only thing that is going to be changed is I'm going to switch the head units in the car and truck. I should have put the IDA-x100 in the vette as well. The interior is red and this deck can be switched to red instead of blue.

    The systems are fantastic and I'd suggest Alpine to anyone wanted a stereo upgrade.
  2. Springthing

    Springthing New Member 1000 Posts

    Good to hear. Just upgraded my sound system as well. Head unit, amp, subs... I've actually got some good sound in there now!
  3. nad

    nad New Member

    Just put a new JVC HD radio in my 2005 1500. It was a major pain because my truck has the OnStar and Chime and all that stuff, so now when I turn my truck on I get this super loud annoying dinging (trying to replicate the factory ding) and my OnStar doesn't work the same, but I don't use it anyway.

    Also, when the volume is turned all the way down, I can still hear a loud buzz on all the speakers. Even if it's a soft song and you turn it up, you can hear the buzz. Can't figure out what could be causing that.

    Anyone else have these problems with it? The harness was expensive to even get the stereo to work to begin with, but now I have to deal with all this.
  4. goodie

    goodie New Member

    Are your power wire and your RCA's running right next to each other?
  5. Z71_guy

    Z71_guy New Member 1000 Posts

    i want to upgrade my system but not really sure what i want , i got two 8in RF hx2 subs in boxes but i also want to put a alpine deck in and maybe speakers also just not sure where to start

Share This Page