Newest Gallery Photos

  1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Vibrating noise near the front at certain speeds since i installed my x-pipe????

Discussion in 'Performance & Fuel' started by Rockstarrchevy81, Jun 7, 2011.

  1. Rockstarrchevy81

    Rockstarrchevy81 Rockstar 3 Years ROTM Winner 1000 Posts

    I was wondering what this could be when i'm going slow pulling out the drive way there is a vibrating noise up where the driver side is and idk what it is. This doesn't do it at high speeds but sometimes after driving and i stop it kinda vibrates and rattles some. Does anoyone know what this could be or experienced this before? Thanks, Jake
     
  2. 98Hotrod98

    98Hotrod98 Rockstar 100 Posts

    Has it going on for a while, or just since you put on the nurf steps??
    Does it sound like a metal rattle or plastic?
     
  3. Rockstarrchevy81

    Rockstarrchevy81 Rockstar 3 Years ROTM Winner 1000 Posts

    Yeah it was happening before i put on the nerf steps so i know it isn't them at all. This happened when i installed my x-pipe and didn't do it when i installed the muffler right before it. This sounds like metal rattling and vibrating some just dont know what it is?
     
  4. darnie1987

    darnie1987 Rockstar 100 Posts

    have you checked all your exhaust mounts? also i was having the same issue " at idle and pulling out" my Exhaust tips were rubbung the bed? idk if its the issue in your case just food for though ? :)
     
  5. Rockstarrchevy81

    Rockstarrchevy81 Rockstar 3 Years ROTM Winner 1000 Posts

    Yeah my tip's don't touch the back end of my truck they are angled out and down enough under the bumper and ligned up so that's not the deal. Idk what it is it only does it when i start going and stop but at higher speeds not a sound at all. I also gotta take my truck back to the muffler shop the guy who put my x-pipe on didn't do it worth a damn. I usually take it to another place but they were oacked so did it at this place. Well to start off he cut my exhaust pipe to put the x-pipe in and didn't measure it so he had get part of a exhaust pipe to cut in the shop and come to find out i look under there the exhuast pipe is bent really bad so i know my flow isn't any better since it's almost like a s shape! I gotta get this done sometime this week and i will not be paying to get this redone being he did the ****ty work lol.

    ---------- Post added at 03:14 PM ---------- Previous post was at 03:04 PM ----------

    Thanks man i guess i'll let it run one day and see what it does and if that's the case just get it welded when i take it to get my exhaust pipe redone where the guy did a ****ty job ha.
     
  6. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    Check the cross over pipe near the trans for the pipe hitting a heat shield.
     
  7. Rockstarrchevy81

    Rockstarrchevy81 Rockstar 3 Years ROTM Winner 1000 Posts

    Thanks man i'll check that too sometime tomorrow i guess. Also it sounds like it's right where my cats are?
     
  8. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    Theres heat shields around the cats and the trans and maybe when they installed the "X" pipe the exhaust is rubbing one of those heatshields. May be rubbing all the time but you here it at lower speeds because of less engine and road noise.
     
  9. Rockstarrchevy81

    Rockstarrchevy81 Rockstar 3 Years ROTM Winner 1000 Posts

    okay man i appreciate it i will check it out sometime tomorrow and see what the deal is shouldnt be too much ha
     

Share This Page