1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Voltmeter and Fuel Gauge Wagging!!! Shop Is Confused!

Discussion in 'GM Powertrain' started by DacMan, May 20, 2012.

  1. DacMan

    DacMan New Member

    Hi everyone I'm new to the forum and just recently bought a 2000 blue x-cab 4 door z71 silverado LT with the 5.3 Vortec. After a few days of driving it I ran into a serious issue. I had it almost die on me and run rough for a few seconds in a parking lot upon start up and therfore took it to napa where they diagnosed the battery was low on cca so i replaced it. Directly after replacing it the voltmeter began to wag when driving it from 13 to 16 volts. Once that happened my shifts got really sloppy and my tow/haul mode stopped working. I then went back and re-replaced the battery thinking it was shorting out internally (no luck) So then i replaced the altenator (no luck) I took it to a shop and they said the multifunction switch was bad (knew that when i bought it) replaced it and... no luck. So at this point im stumped. It doesn't always have the two gauges wag (or shake if you will), i drove it for three days with no problem but they still do it sometime (also tow/haul still won't come on) Any help would be in-valuble!

    Thanks, DacMan
  2. dipstick

    dipstick New Member

    For it to show that much over charge would thick alternator. Or gauge is wrong... test alt.. and battery charge with meter .
  3. DacMan

    DacMan New Member

Share This Page