Newest Gallery Photos

  1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Weird Issue with 07 Silverado

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by ctruhn, Jun 30, 2007.

  1. ctruhn

    ctruhn New Member

    First off details on my truck:

    2007 Silverado 1500 LTZ Extended Cab (new body style)
    Black on Black (I love it!)
    Z71 4x4
    2K Miles

    First off, I LOVE this truck. Everything about it. Well until this. :)

    I have a Garmin C340 portable GPS that I love. I bought it late last year and it has saved me a few times. Well today I plug it up to look for a certain store and all of a sudden the windshield washer fluid starts flowing from the wipers. The wipers move and all just like if I were to have been holding the toggle down.

    I first saw this about a month ago but didn't know wtf was going on. I didn't relate it to the GPS at all. It kinda worried me but I didn't pursue it as it only happened for about 20 seconds and didn't happen again.

    Well today as soon as I plugged the GPS in it happened again. So I reached down and unplugged it and magically the wipers stopped! I plugged it back in and it did it again! So I thought maybe it was an electrical issue and my GPS has a battery backup so I kept it unplugged but turned on GPS on battery and once again it did it.

    It runs for like 20-30 seconds then stops. About a minute later it will clean my windshield again but just for 2-3 wipes and then it doesn't do it anymore.

    So I know it isn't just an electrical issue with the outlet I am using. I suppose it causes some sort of interference with the computers somehow and I think once it detects it's satellites the wipers stop.

    Also to note - I do not have automatic wipers. I know the Dual Cab's do and so do some of the SUV's but my truck does not.

    I also don't think this happens every time I use the GPS. I know this has only happened twice and I am pretty sure I have used my GPS more than twice in this truck. It is just annoying to no end.

    Has anyone ever heard of this? Any ideas as to if I should complain to Chevy or Garmin?
     
    Last edited: Jun 30, 2007
  2. GaryL

    GaryL Epic Member 5+ Years ROTM Winner 1000 Posts Platinum Contributor

    I have never heard of this, but I would contact Chevy first and then Garmin. Hopefully it will only mess with the w/s wipers and not the air bags or ABS. Keep us posted.
     
  3. 84fiero123

    84fiero123 Epic Member 5+ Years 1000 Posts Platinum Contributor

    Very interesting.

    You said

     
  4. unplugged

    unplugged Epic Member 5+ Years 1000 Posts

    Three little letters

    EMI (Electro Magnetic Interference)
    I use MS Streets and Trips with a gps sensor attached to my laptop. No interference issues with my 06 Silverado. Part 15 of the FCC regs require that receivers be labeled:
    I would contact Garmin and have the unit replaced.
     
  5. Rumpamuro

    Rumpamuro Rockstar 100 Posts

    My friend had the same issue with his tom tom 550 or somrthign like that, i told him to complain to tomtom, when he did, they made him try it in another vehicle, it didnt happen, so they told him there was somethign wrong with his truck, he went to buick (it was a rendezvous) and bucik told him it was interfering with the bcm, they actually went out, bought another unit, (same one) and nothign happened, they called tomtom and tomtom refunded them 100% and my buddy got unlimited maps or something like that for them being wrong.
     
  6. Rumpamuro

    Rumpamuro Rockstar 100 Posts

    they alsosaind somthing with his antenna being on the windshield, but i and everyone else ive asked thinks that was just some excuse to get him out of there. but you never know, is your antenna on the windshield like the circuit board type?
     
  7. 84fiero123

    84fiero123 Epic Member 5+ Years 1000 Posts Platinum Contributor

    EMI, ah that’s the name of it.

    I knew someone would know the name of the problem.
     
  8. ctruhn

    ctruhn New Member

    Cool. Thanks for your help guys. I will call Garmin today and if I get nothing from them I will call my dealer.

    I used it again later that day and nothing happened. Though now I am getting the message "Washer fluid low"! :rofl:
     
  9. GaryL

    GaryL Epic Member 5+ Years ROTM Winner 1000 Posts Platinum Contributor


    Have you checked your washer fluid? ;)
     
  10. tbplus10

    tbplus10 Epic Member Staff Member 5+ Years 5000 Posts Platinum Contributor

    Yep sounds like EMI. Automotive systems arent required to use shielded cables and wiring. In aviation all aircraft components and wiring are required to be sheilded due to accidents attributed to EMI on fly by wire aircraft.
    Something else to watch for is "On Star", there have been a few reports of minor issues when using accessories in vehicles with On Star.
     

Share This Page