1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Weird rear brake light problem

Discussion in 'General Chevy & GM Tech Questions' started by fingerz, May 14, 2012.

  1. fingerz

    fingerz New Member

    Hi I'm new to the forum hopefully someone can help me here.

    So I have a 99 suburban k1500 4x4 2 years back my break light and turns signals started to act up replaced multi function switch and everything was good. Now I'm here today and my brake lights are not functioning. Let me start by saying my 3rd brake light has never worked in the 6 years I have owned the truck. All my signals are working including hazards. All my running lights are working. Just my brake lights will not function.

    I can see the wires to the multi function switch but I can't find anywhere on the internet on which wires to test while depressing the brake as I know they go through there. I can't really get at the brake switch wires to test them with ease anyway so I was hoping there is another point where I can test them. I do not have a brake fuse or relay under the hood there are spots but no connectors. I'm hoping someone can tell me what wires in the multi function harness to test or provide me with another solution.

Share This Page