Newest Gallery Photos

  1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

what am i doing wrong?

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by 89suburban350, May 21, 2007.

  1. 89suburban350

    89suburban350 Rockstar 100 Posts

    ok so i am installing my aiwa CD-304 cd reciever and i have the wiring harness ready and now it wont turn on? its a brand new HU..... i changed the radio and Horn/DM fuse and it still wont work...
  2. collinsperformance

    collinsperformance Epic Member 5+ Years 500 Posts

    does the horn and cig lighter work? if not look at a blown fuse. if they do look at your wireing it not correct....did you get a kit and if so who made it?...mike
  3. 89suburban350

    89suburban350 Rockstar 100 Posts

    yep the horn and cig lighter works. just changed that fuse 2 days ago... and stingpro makes my harness...
  4. Crawdaddy

    Crawdaddy Thread Killer Extraordinaire Staff Member 5+ Years 1000 Posts Platinum Contributor

    I'm not familiar with that brand of wiring harness, but double-check your connections, both physically and to make sure that you have the appropriate wire meeting up with the correct wire. If the wiring harness does not have the industry standards color codes on it, I wouldn't use it, simply because it would be so easy for the company to keep up with the industry color codes. The ones you really want to double check good are your red, yellow, and black wires. Speaking of the black wire, you may also want to provide a second ground to a metal part of the chassis to make sure that the ground in the wiring harness is really good.

Share This Page