1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

what happened??????

Discussion in 'Chevy Uplander & GM Minivan Forum' started by GM_Guy, Mar 28, 2007.

  1. GM_Guy

    GM_Guy New Member

    as I was coming home in my 82 GMC van early this am, I was preparing to turn in my driveway, engine suddenly quit, and now will not re start. it simply cranks (kind of fast), will not fire. it was running very good up until it quit. I have to get it pulled in to my yard first before I can remove the outhouse, to look at the engine. what went wrong??????
  2. TrailLeadr

    TrailLeadr New Member 1000 Posts

    Busted flexplate maybe.
    Although engines don't usually stall from that, they just don't ever start again.
    Can you hear the engine turning over, or just the sound of the starter spinning quick.
    Can you see if your distributor rotor spins when you crank it.
  3. GM_Guy

    GM_Guy New Member

    I will have to check when I get it pulled in my yard,it's sitting on the street now
    I did a quick check,and the engine is turning over,(put mark on alt fan, it moved after cranking it for a sec) can't do much else to it where it sits now. was running smoothly before it happened
  4. ChevyFan

    ChevyFan Administrator Staff Member 1000 Posts

    fuel pump? Pop the line and see if any fuel comes out. I've had this happen before, mind you on a FoMoCo. Driving down the road it it just died without warning.
    Last edited: Mar 28, 2007
  5. GM_Guy

    GM_Guy New Member

    I got it pulled in the yard, rotor is turning, and is getting fuel. pulled a plug wire, and stuck a plug in to it, and placed it close to ground, I saw no spark. so, I'll pull the module first, and see if it's bad
    Last edited: Mar 28, 2007
  6. Davandy

    Davandy Moderator 1000 Posts

    I bet my money on the module :he:
  7. Cableguy

    Cableguy New Member 1000 Posts

    Ok I'll bite. Cap, rotor and module.
  8. GM_Guy

    GM_Guy New Member

    was the module. took it to have tested, failed miserably.
    put a new one in, runs great again!!
  9. Cableguy

    Cableguy New Member 1000 Posts

    Good for you she's alive again! What did me and Davandy win :lol:
  10. ChevyFan

    ChevyFan Administrator Staff Member 1000 Posts

    At least it failed near home. I've broken down 1000 miles from home before while I was going away to work for the summer. Not fun.

    Glad you're back in the saddle again! :party:

Share This Page