What have u done to ur GM truck today?

Discussion in 'Chevy Truck Talk & GM News' started by devilsalmostfree, Feb 28, 2010.

Thread Status:
Not open for further replies.
  1. pmf608

    pmf608 Epic Member 5+ Years 1000 Posts

    After just over a year of having it, I finally took mine in and had a new windshield installed today. It's nice to be able to see again...
     
  2. ahmitchell1

    ahmitchell1 Rockstar 4 Years ROTM Winner 1000 Posts

    Got my intune set up in my truck now gotta figure out how to tweak the little stuff
     
  3. rileyjr16

    rileyjr16 Rockstar 3 Years 1000 Posts

    Well today around (0700) I'm gonna take EVERYTHING out and give her a cleaning. Seats, carpet, dash pieces, door and other panels are coming out for ALOT of cleaning and I might have some help from K
     
  4. Ape

    Ape Member 100 Posts

    I had this problem last year too. Thought it was my alt because I was having electrical issues too. After 3 alts and lots of annoying squeeking I found it was a shorted wire for the charging problem. And the squealing was a tensioner pulley.
    Long story short.....I replaced the pulley and wound up having to replace the rest later because they were going bad as well. So I'd replace the rest while you're there and save the later headaches.
     
  5. PantheraUncia

    PantheraUncia Active Member 3 Years 1000 Posts

    Ordered more Putco 914 LED's for my truck, mainly interior lights. ( under dash, glove box, ashe tray, etc), bought from Amazon instead of locally to try and save some money.
     
  6. Coach24

    Coach24 Rockstar 3 Years 5000 Posts

    Wow you will have a regular night life pick 'em up
     
  7. UpsetProps

    UpsetProps Member 2 Years 100 Posts

    Got my Diablosport Trinity today.....was super excited to try it out.

    Wanted to pop on the 87 octane tune to see what kind of performance boost it gave, then I planned to load the MPG booster tune for my road trip which is going to take most of August.

    As soon as I was able to load the 87 octane tune the cable that connects to the bottom of the unit from the OBDII port broke and fell out.

    Looks like I am stuck with the 87 octane tune for my roadtrip now.......so much for saving gas. I just hope when I get home and get a new connector in the mail that solves the problem and it is not the internal side of the connection as well. Since some of the connector pins in the unit look bent as well.
     

    Attached Files:

  8. pmf608

    pmf608 Epic Member 5+ Years 1000 Posts

    I noticed that my rear diff was leaking pretty badly this afternoon. I stopped by the Napa near my jobsite and picked up some gear oil to top up until I could get home. It was down by over a quart. Then once I got home (without too many nasty sounds from the diff) I pulled the cover, scraped the gasket and used silicone to make a new gasket. Once it sets in a while, I'll go out and tighten all the bolts a bit more and refill it.
     
  9. PantheraUncia

    PantheraUncia Active Member 3 Years 1000 Posts

    More LED's for the inside of the truck have shipped.... should have them by friday for installation.

    Bought new rotors all the way around and new E-Brake shoes to install on the rear wheels. Should be doing that Saturday afternoon and my replacement bumper sits in the garage rusting away cause it is a pain in the ....... to put together.....

    Looking to pick up 15 meters of weatherproof LED strips to wire at various places around the interior and exterior of the truck with dimmers and maybe go with color changing strips instead of straight 6000k white.
     
  10. Big_Mike

    Big_Mike Member 100 Posts

    Looked up information to install a CD player and am about to go paint the radiator support!
     
Thread Status:
Not open for further replies.

Share This Page

Newest Gallery Photos