What's rattling in my ceiling?

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by blackbeard, Jun 11, 2010.

Newest Photos

  1. blackbeard

    blackbeard New Member

    Hi,
    in my 2002 Suburban (1500 LT Premium w/Onstar) I have what appears like a
    small vent or grille mounted in the ceiling just above the drivers seat.
    It is about 3/4 of an inch across, circular and filled with holes (like a speaker grille).
    It is made out of plastic and appears very much factory-made (same color as center
    console).

    In the last week or so, there is a rattling noise coming from the vent. It could be a mechanical
    rattling (like a small fan hitting something) or an electrical noise (like static in a speaker), The noise
    is loudest just when I have started the truck and then gradually fades away.

    So: does anyone know what the vent is? Why does it make a noise? How can I fix it?

    Thanks,
    /Hans
  2. DTACA Burban

    DTACA Burban New Member

    Hi there, My '02 has (had the same problem). It is the speaker for the Onstar system. Seen as how you cannot use the Onstar anymore in that year this is a simple fix. Pry off the little speaker grill and then carefully pull the edge of the headliner down above the drivers door and unplugged the wire to the speaker. I then removed the speaker box and put the speaker grill back in the hole. you will never know its gone. A side note would be that you are only going to have a small space to work in. It took me about three tries to get it out once the wire was diconnected. Good luck... That noise drove me crazy on startup. It is the same as am radio feedback that used to be common.
    Last edited: Jun 12, 2010
  3. Joeairforce

    Joeairforce New Member 100 Posts

    WRONG...... It's a vent/sensor for the auto climate control..... It has absolutely NOTHING to do with Onstar..... Take that out and the auto climate control won't work right...... There's a little fan inside it...... Some people have carefully took them apart and cleaned them up and the noise quit...

    The Onstar uses the vehicle stereo speakers and the little mic in the mirror or clipped to the overhead console....
    Last edited: Jun 13, 2010
  4. blackbeard

    blackbeard New Member

    OK,
    so I have one guy saying "cut it" and another saying "take it out and clean it".
    Good I am not a vet who was fixing dogs... :)

    Joeinairforce: Do you know how to get it out? It doesn't unscrew from the outside -
    do I have to drop the headliner?

    Thanks,
    /Hans
  5. DTACA Burban

    DTACA Burban New Member

    Well if i'm wrong then I'm wrong. My Auto Climate control still works perfectly and has for the last 8 months since I removed that box. Sorry to lead you astray blackbeard. Good luck with your fix.
  6. Joeairforce

    Joeairforce New Member 100 Posts

    Yes, I believe you have to drop the headliner..... I could be wrong though..... Never had to take one out before so not sure on that.
  7. Ronny

    Ronny New Member

    I have a 03 CHEVY Suburban 8,1 liter LT Autoride....wow....long name, but anyhows, have the same rattling noise......annoying.
    Thanks for the tips, I see I now must investigate !
  8. trapperdon

    trapperdon New Member 100 Posts

    i hate to say it, but.... have you tried to get the stealership in your area to
    diagnose or come up with an answer by telephone before you invest time into messing with it??
    they should be able to tell you exactly what it is or how to pull the cover off unless
    the just wanna take your money and run....

    i always tell em you help me with the small trivial stuff and i'll come to you for the heavy work... :great:
  9. DTACA Burban

    DTACA Burban New Member

    Well... I just found that switch in my pile of stuff and joeairforce is right. I never looked close enough at it to see that it is a tiny fan assembly... So i guess thats what happens when you don't pay attention.
  10. cwgburban

    cwgburban New Member

    I have a 2003 LT with dual air, the one in the back made the same noise and I unhooked it from the harness. Auto A/C still worked in the front and I usually don't run the one in the back.
    Now I understand what this thing does.... The one in the front over the driver started the rachet and I unhooked it, no auto A/C. The default mode is you have to put the heat on 90 and the A/C on 60.

    I will try cleaning them. Does anyone know where to get new ones, I have tried searches, but have not been able to find them.

Share This Page