Where is the pulse switch for the wiper motor located on 1989 chevy silverado?

Discussion in 'Chevy C/K Truck Forum' started by Porter148, Jan 23, 2011.

  1. Porter148

    Porter148 New Member

    Im having some problems with my wipers turning off after they have been on. Sometimes they work like a charm. Then it seems after the truck warms up they act up and most of the time only go fast or dont turn off.
    I was thinking the pulse board was under the dash somewhere but i cant find it. Thanks for any help!
     
  2. pino55

    pino55 New Member

    The delay module is on the wiper motor. Mine was doing the same thing and it wasn't that at all. I had a short in my system from the light socket boards on the tail lights corroding and rusting causing a short in the electrical. Check for shorts in the system.
     
  3. okysmokey911

    okysmokey911 Rockstar 100 Posts

    Yes it is on the motor and when I replaced mine it fixed the problem for about a month or so, but its back to doing the same thing you described. I agree look for shorts.
     
  4. ScubaSteveo

    ScubaSteveo New Member

    Fixed mine 2 years ago and still working fine. Easy to replace also
     
  5. Chris Miller

    Chris Miller Rockstar 100 Posts

    It's very likely the pulse board. It was recalled for 88-98 models with intermittent wipers, due to the exact problem you describe.
     
  6. ejohnson03

    ejohnson03 Epic Member 5+ Years 1000 Posts

    I am having same issue... would that also effect the washer fluid spray to not work sometimes?
     

Share This Page

Newest Gallery Photos