1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

which to replace first

Discussion in 'GM Powertrain' started by somonenew1994, Feb 28, 2010.

  1. somonenew1994

    somonenew1994 New Member

    ALright i have been doing a motor swap now i used my orginally heads a intake for the vortec. Now when i go to start it i have now spark what so ever no going to the plugs and i pulled off my wire coming off my coil and i dont get spark there either so i was wonder should i just try to replace the coil or should i try to replace the ignition control module first difference in price is the coil is about 37 and than the icm is about 80 any thoughts of which fisrt or could there be something else that woulnt let me get spark thank you jay
  2. Silverado Junkie

    Silverado Junkie New Member 100 Posts

    Id change out the coil first since its cheaper.
  3. ejohnson03

    ejohnson03 New Member 1000 Posts 100 Posts

    Could also be the Ignition Control Module...:gasp:
  4. somonenew1994

    somonenew1994 New Member

    alright i replaced both still no spark the cap and rotor was replaced about 20 to 30,000 ago along with plugs and wires and now i am sitting here dumbfounded i really would hate to take it to someone else and have to pay for it to get fixed
  5. BASSIST

    BASSIST New Member 100 Posts

    Did you remember to connect the crank sensor when you connected everything up? If the crank sensor is not connected or is bad there will be no spark.
  6. somonenew1994

    somonenew1994 New Member

    its connected but i dont think it could of just went bad cause b4 i did the motor swap it did run but on the replacment motor i had to switch the timing covers could it be that there is a after market cam in it ? amd i was also told that if i am 180 off in my timing that i wouldnt get spark is that true?
    Last edited: Mar 1, 2010
  7. somonenew1994

    somonenew1994 New Member

    alight i figured out one problem and got that fixed and than i started working on spark again pulled the cap off rotated it 180 and than put back on my cap and got spark so i went on trying to get her started and than i lost spark again so back with no spark i think the next thing i am going to repalce is the cap and rotor figured i heard a few people say they have changed them and they went bad no long after that so if you all have any other ideas let me know i am open to anything right now
  8. somonenew1994

    somonenew1994 New Member

    alright got spark back for a min it comes and goes i actually had it running for a few min today so now i am wondering if the bracket anit grounded enough that holds the icm and coil pack i replaced the cap and rotor at first i didnt have spark but than i played with the bracket and got spark so we are going to top off fluids and try to get the timing right and running good

Share This Page