1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

White smoke on start up

Discussion in 'Chevy Avalanche Forum (Escalade EXT)' started by Dctackett10, Mar 8, 2014.

  1. Dctackett10

    Dctackett10 Member

    Guys I need some help. I have a 2008 avalanche LT with close to 120,000 miles on it.

    i have just notice after starting my truck there is a white grayish smoke coming from the exhaust pipes. The smoke is very noticeable but isn't a lot that you can't see or anything like that. It will smoke for about 3 minutes and then about 30 seconds after driving it. The check engine light isn't on and I haven't notice any problems in performance wise.


    I don't think it's water or condensation because it does it when it's about 60 degrees outside. I just recently changed the oil pressure sensor, you think it could be something with that.

    Checked all the fluids level, they where fine. Oil might of been a quart low. Just changed the oil and put 10W30 in it instead of the 5W30 that I have been using.

    Any my idea what could be causing it to just start smoking like that at start up, it's not effecting performance. It's just embarrassing when I start the truck up?

    help please!!
  2. Enkeiavalanche

    Enkeiavalanche Rockstar 4 Years ROTM Winner 5000 Posts

    You are in Trouble you are out of warranty and sounds like you have the Oil Conception case Look it up on here There are a few people like me who had it.. Mine was fixed at 86K

    And Welcome..
  3. Dctackett10

    Dctackett10 Member


    Well I renewed the warranty for upto 200,000 miles. But I think it's power train only. Does this fall into that category. Sorry. I'm a noob at mechanic parts lol

    but. What you mean. Look it up on here, what do I need to type in?

    Thanks for the reply
  4. Enkeiavalanche

    Enkeiavalanche Rockstar 4 Years ROTM Winner 5000 Posts

  5. Dctackett10

    Dctackett10 Member

    It says invalid link
  6. Enkeiavalanche

    Enkeiavalanche Rockstar 4 Years ROTM Winner 5000 Posts

  7. Dctackett10

    Dctackett10 Member

    How long after the white smoke on start does the problems start to follow. As for mine. Right now. It's just a bit of little white smoke when it starts up. There's no problem when driving it. Not using much oil either

    i just changed the oil. Gonna monitor it through out until next oil change.

    Could it just be the valve seals. Or do you think in wasting my time with that

    - - - Updated - - -

    I recently just changed the oil pressure sensor cause it went out. You think they could be a problem due to that?

Share This Page