1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

wierd motor shake on k1500 350 tbi

Discussion in 'GM Powertrain' started by quicksilver8817, May 10, 2012.

  1. quicksilver8817

    quicksilver8817 Rockstar 100 Posts

    so my motor shakes my truck while driving but at low rpm and is great during harder acceleration. im sure its a motor issues because it doesnt do it while cruising in neutral . Its also fine in park.. ill get a video up when i get a chance ...
  2. rileyjr16

    rileyjr16 Rockstar 3 Years 1000 Posts

    What do you mean by shake? A vibration or a violent shake? Check your motor mounts as that would be the first thing I'd check
  3. dpeter

    dpeter Rockstar 3 Years 100 Posts

    Universal joints. Check em
  4. quicksilver8817

    quicksilver8817 Rockstar 100 Posts

    just did u joints .. and it had a tune up about 3 months ago .. how do i check my motor mounts?
  5. rileyjr16

    rileyjr16 Rockstar 3 Years 1000 Posts

    Its not the U joints. If it cruises with no shakes in neutral, the driveshaft still turns when cruising so thats ruled out from the start. As to checking the motor mounts, open the hood and have someone put it in and out of gear R,N, and D. The motor should jerk from the transmission kicking in and out of gear. How much it would jerk I have no idea, but if the mounts are good, it shouldn't jerk much. Or if you can use an inspection mirror so look for cracks or any signs of wear use that.

    However it could not be the motor mouts at all.


    Read my disclaimer in my sig though.
  6. dustdevil

    dustdevil New Member

    On some vehicles you can check motor mounts by brake reving the engine, dont try to break the tires loose just blip the throttle several times. Open the hood start engine put in drive hold brake and blip the throttle.watch the engine for excessive movement. Then put trans in reverse and try again. As a general rule your looking for more than a couple inches,if they are bad it SHOULD be obvious.
  7. dpeter

    dpeter Rockstar 3 Years 100 Posts

    rileyjr16, based my suggestion on the u-joints on the point the op made about shakes under load. Bad u-joints can present with several symptoms and one of them is exposed only under load. Maybe bad joints or or not lined up if a two piece shaft and especialy now that we know u-joints were replaced recently, all the more reason to double check them.
  8. quicksilver8817

    quicksilver8817 Rockstar 100 Posts

    it was doing that before the u joints .. they were replaced because one failed .. and its almost like a wobble than a vibration
  9. carmantx

    carmantx Member

    It doesn't shake when you are in neutral or park? You can rev the engine in park and no shake? If so, that rules out your engine.

    You had a u joint fail? which one? And did you replace all of them on both front and rear shafts?

    I would check them all first. A bad u joint can be rough under acceleration, and smooth out while coasting.
  10. dpeter

    dpeter Rockstar 3 Years 100 Posts

    Can you duplicate the shake while standing still. By that I mean are you able to put it in drive and while holding the brakes then put a load on the motor and get it to do it?

Share This Page