1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Windshield Washer Pump not working (not the pump)

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by vdubn, Nov 2, 2009.

  1. vdubn

    vdubn New Member

    I have a 99 Suburban that is having an issue, basically the washer pump will not pump at all, no noise, nothing.

    So after testing the pump (running voltage to the pump from the plug on the inner fender), it works, but not when using the wiper switch. I checked voltage at the same plug on the inner fender, and its like 1.5v, so I am thinking that it must be the switch itself (part of the wiper and cruise control combo switch on the column).

    But, at over $200 for this switch, I am hoping to try and do some additional testing to make sure first.

    I know there have been a lot of issues with the washer motors on these trucks, but I wanted to see if there were any known issues with the cruise/wiper switch stalk?

    Any help is greatly appreciated.
  2. jordan.coquat

    jordan.coquat New Member

    i have a 97 that had the same prob, had to replace the wirper motor...
  3. andreasue

    andreasue New Member

    You might have a bad pump or there is a problem with the wiring itself or maybe the switch itself. Just look for surplus parts if you want to save money. $200 for the switch is already painful.
  4. WEEBOB

    WEEBOB New Member

    my 99 suburban did that same thing i chased it to the wiper module on the wiper motor, all things work well now,,, cost $ 35? car quest, easy fix, the wiper delay started to act funny ,that's how i found out, it also works the washer pump, just my input,,,,,
  5. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    The wiper motor circut board is a very common issue with these trucks, so id take a look there as well.

Share This Page