wipers dont work.

Discussion in 'Chevy Colorado Forum (GMC Canyon)' started by seffieldvillage@aol.com, Oct 16, 2009.

  1. seffieldvillage@aol.com

    seffieldvillage@aol.com Rockstar 100 Posts

    hi well i just can seem to get my wipers to work. i blow the fuse in my left headlight and put a new one in, now the headlights work but no wipers. i scanned it but no codes. help ralph forgot 2004 colorado
     
  2. vncj96

    vncj96 Epic Member 5+ Years 1000 Posts

    Check the connections at the wiper motor, it should be right in front of the driver on the firewall in the engine bay.
     
  3. seffieldvillage@aol.com

    seffieldvillage@aol.com Rockstar 100 Posts

    check

    hi i checked that. looks good. there is no power therewith the key on. is there a safe way to jump the relays.
     
  4. J.mesenbrink

    J.mesenbrink New Member

    I would trace the hot wire running from the motor for the wipers and see if it's arcing out on the body, if so patch the wire and try it. If not, follow it further and see if you have an unplugged switch, etc. On this new of a vehicle it shouldn't be too hard to figure out the problem.
     
  5. seffieldvillage@aol.com

    seffieldvillage@aol.com Rockstar 100 Posts

    worked

    hi they worked until i blow the fuse in the headlight.
     
  6. bricssig73

    bricssig73 New Member

    wipers dont work

    i checked the fuses, sprayed the wiper assembly with wd40, and made sure i didnt overtighten the wipers, and still nothing im guessing the motor is burnt out, it was working about 2 weeks ago
     

Share This Page

Newest Gallery Photos