1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Wont crank.

Discussion in 'GM Powertrain' started by Santoy956, Jun 15, 2010.

  1. Santoy956

    Santoy956 Member

    I have a 2000 z71 silverado 5.3l and it wouldnt start at all after 20min of being turned off. I checked everything and all relays are fine and all grounds are in place and the battery was good. It would turn on all the accesories with no problem. It wont CRANK!!!!!!!:grrrrrr::grrrrrr::grrrrrr:
  2. k.daddy1

    k.daddy1 Rockstar 100 Posts

    If you have a multimeter, check if your getting 12 volts to the solenoid on the starter with the key turned in the start position. If your not getting 12 volts, it's a good possibility your ignition switch is bad. I just had the same problem on a 01 chevy.
  3. MrShorty

    MrShorty Epic Member Staff Member 5+ Years 1000 Posts

    For me, this problem is most often caused by a bad/loose connection at the battery. It takes so much more current to crank the engine than to run accessories.

    It's not common, but I have had a battery that would test good even though it was bad.
  4. Santoy956

    Santoy956 Member

    thanks guys it turned out to be som lose conections on the starter

Share This Page