1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

XM Radio Quit Working

Discussion in 'Audio, Video & Gadget Tech' started by kevindsingleton, May 2, 2011.

  1. kevindsingleton

    kevindsingleton Rockstar

    The XM radio in my 2009 Silverado quit working. It will only tune to channels 0, 1, and 247. I called XM, and they "reset" the radio, but nothing changed. XM tech support suggested taking the truck to the dealer, but the radio "works". AM/FM/CD is fine, and it still tunes and plays audio on the three XM stations it will display.

    Anybody else deal with this, and how'd you fix it?
     
  2. GM Customer Service

    GM Customer Service Rockstar 4 Years 500 Posts

    I would also have to recommend contacting the dealership regarding this concern. Even if this does not turn out to be some kind of issue with the unit itself, the dealership may be able to work with XM in order to resolve the concern. Please feel free to keep me updated regarding the concern. Thank you.

    Tricia, GM Customer Service.
     
  3. bart6180

    bart6180 Member

    did you have the radio turned on when they tried resetting it, you can actually send a reset signal from the xm website instead of dealing with the idiot indian people that make up their customer service department. the 3 channels your getting are pretty much the sample channels that you receive without having a subscription, if something was wrong with the radio, you woulden't be receiving any channels at all.
     
  4. hotrodking86

    hotrodking86 Rockstar 100 Posts

    I agree. If it didn't work than why are those 3 channels working? Are you making sure to allow the subscription to register? I know that I leave my radio on for like 15 minutes just to make sure that the signal has registered. Just a thought
     
  5. sstoner911

    sstoner911 Epic Member 5+ Years 1000 Posts

    Did you pay the bill? :)

    Make sure the radio is on while your refreshihg the signal as mentioned above.
     
  6. ajarman

    ajarman Rockstar 4 Years ROTM Winner 1000 Posts

    You beat me to it sstoner!!
     
  7. kevindsingleton

    kevindsingleton Rockstar

    I did what they told me to do, while I was on the phone with them. Sometimes it was on, sometimes it was off. We went through every permutation: no joy.

    I agree that it's not the unit, and I explained that to the techs. The same thing happened when my first year subscription rolled over, but they were able to "reset" it, then. This time, they don't seem to be as ...effective.

    ---------- Post added at 08:29 AM ---------- Previous post was at 08:27 AM ----------

    It was on when they told me to turn it on, and off when they told me to turn it off. I spent a couple of hours on the phone with their technicians. I've had the subscription since 2005, from a portable unit, which I switched to the radio in the Silverado in March, '09.

    ---------- Post added at 08:29 AM ---------- Previous post was at 08:29 AM ----------

    Yeah, it's a subscription that automatically renews from my checking account. I've had the subscription since 2005.
     
  8. NCN8ive

    NCN8ive Rockstar 100 Posts

    Have you checked your portable unit to see if for some silly reason the subscription reverted back to it?
     
  9. kevindsingleton

    kevindsingleton Rockstar

    I didn't think of trying that ...because I sold it two years ago! Good idea, though!
     
  10. Cwaynew

    Cwaynew New Member

    So, I just bought an '09 silverado, used of course, and at the urging of my brother decided to try out XM. I'm having the same issues everyone here is having. Reset at least four times, and still only receive channels 0 and 1. I can hear the preview well, but no other channels. Just like many of you, XM told me to take it to the dealer. Well the dealer can't get me in until monday but I have no time.

    Have any of you already been to service over this issue? If so, what is the verdict?
     

Share This Page