GM Truck Club Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-8 of 8 Results
  1. Member Introductions
    starting issues after refuel .Replaced charcoal canister, purge valve, purge valve solonoid.Was having fueling problem. That took care of that , but found charcoal in vent lines coming off of canister.After fue!ing truck will not start. Blow air in tank vent line has back pressure on 3/8 line...
  2. Chevy C/K Truck Forum
    Hey guys, I'm dealing with a 98 gmc sierra k1500 5.7L. Ran fine when it was parked. Now the blinkers and the high beam indicator on the dashboard stay on even with no key in the ignition. Seems like the fuel pump isn't engaging. 0 pressure at the bleeder. Pump was changed 25k miles ago...
  3. Chevy Silverado Forum (GMC Sierra)
    2000 Chevy Silverado 5.3 crank but no start. Had this problem and it was the fuel pump replaced pump and filter was driving fine and then it just wouldn’t turn back on one day. There was no warning signs or anything just quit. Thought maybe it was the fuel pump so I replaced it again (it was...
  4. Chevy C/K Truck Forum
    I’m working on a 1994 GMC c1500 TBI 5.7 v8. I hadn’t started it in 5 days and it started with the first turn of the key today! But after letting it idle for 10 minutes, I shut it off and when I went to start it back up it would only crank over. When I opened the throttle all the way it would...
  5. Chevy C/K Truck Forum
    Two seperate issues. When I could get the truck to run it would die on the road after about fifteen minutes. Then it had trouble every now and then starting up. Sometimes a rough idle. This is a list of what I have changed. Spark plugs tune up(wires, rotor, and cap included) Ignition coil Iac...
  6. Chevy C/K Truck Forum
    I bought a lifted 95 chevy Silverado 5.7 l v8 tbi. It's been a money pit and a real bitch... it ran 98 miles home. First week runs and starts fine then I replaced passenger exhaust manifold.. the next morning no spark. (I have checked flat cable ground by manifold and seems to be intact). So...
  7. Performance & Fuel
    Hi I have a 2001 2500HD gas powered 6.0 Longbed. I've been having a intermittent starting problem for some time now. The truck never leaves me stranded, eventually it starts. I replaced the battery, I've removed the throttle body and cleaned. I brushed the cold start sensor. I've replaced the...
  8. Chevy C/K Truck Forum
    Hey guys i have a 1998 k 1500 that I've been restoring i put a new engine wiring harness every sensor is brand new just about everything on the engine is brand new aside from the alternator and intake manifold. I know for a fact the crankshaft position sensor works and the reluctor wheel is in...
1-8 of 8 Results
Top