GM Truck Club Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. Chevy C/K Truck Forum
    Hey guys, I'm dealing with a 98 gmc sierra k1500 5.7L. Ran fine when it was parked. Now the blinkers and the high beam indicator on the dashboard stay on even with no key in the ignition. Seems like the fuel pump isn't engaging. 0 pressure at the bleeder. Pump was changed 25k miles ago...
  2. Chevy C/K Truck Forum
    Hello, I have a 97 Chevy K3500 flatbed that one of the fuel pumps is starting to whine a little. It has two fuel tanks that automatically switch or I believe the rear tank pumps into the front tank somehow. I am looking for any info on how the fuel system works. A schematic would be great of how...
  3. Chevy Trailblazer Forum (GMC Envoy)
    2004 GMC Envoy 4.2 EX/SLT I installed a new fuel pump and had to wire a new harness into it because of the aftermarket pump. Disconnected the battery before I even started anything and did not reconnect it until I was completely done. Problem I have right now is I'm not getting any power going...
  4. Chevy Silverado Forum (GMC Sierra)
    Hello!! I have an '08 Chevy Silverado 1500 4WD with a V8 6.0L engine. It is not a FlexFuel. Originally I had taken it to Autozone to use their diagnostic device and it threw up a code that said I had "dirty fuel injectors." So I have used the Lucas brand Fuel injector cleaner in my fuel tank...
  5. Chevy C/K Truck Forum
    I have an 89 chevy 1 ton crew cab (I think it was an old forest service truck) it is the older style square body, 350 tbi model with the fuel module unit. To tell a little back story, I had not driven the truck in a few years and was thinking about selling it. I charged the battery and fired it...
1-5 of 5 Results
Top