GM Truck Club Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-8 of 8 Results
  1. Chevy Suburban Forum (GMC Yukon XL)
    Hey guys, new member here...puzzled with this truck, and though I've searched and read on this subject for hours, I'm hoping someone may be able to relate to this specific experience a little more. Just purchased 05 Yukon XL Denali (6.0), 175k miles. Truck ran and drove excellent upon...
  2. General Chevy & GM Tech Questions
    So I have an 05 Seirra 4WD and a low oil pressure light keeps coming on, i'm not sure why this is, but it's usually after I've been driving for about 30 min, or when i stop but my oil gauge drops. i've replaced the sensor already and i am still having this issue. Do I need a new engine, or is...
  3. Chevy C/K Truck Forum
    Have changed both sensors and dropped the oil pan cleaned the screen and still no oil pressure any ideas
  4. Chevy C/K Truck Forum
    Hi I have a 1998 k2500 Cheyenne with about 305000 miles. It have the 5.7L v8. The issue I am having is that the truck has low oil pressure and idle at a stop. The pressure and idle is fine when you first start the truck but as you go you can the oil pressure drop. It usally drops to around 20...
  5. Chevy Silverado Forum (GMC Sierra)
    My 05 has had some issues with the oil pressure lately. Whenever it’s started up it is very dry and loud, the link is when I haven’t driven it in 2 days. It won’t sound as bad if it was only 1 day and it’s not noticeable to a regular start up if it’s been multiple times in 1 day (the cluster...
  6. Chevy Suburban Forum (GMC Yukon XL)
    Hi. Purchased a 2019 XL 5.3. It’s got about 50k miles. Last weekend I changed all the fluids. Drove it today and when idling the oil pressure dropped to a hair below 30. Normal? I’ve never had a vehicle drop like that when idling. Also when idling every 10 seconds or so I feel a very light...
  7. Chevy Avalanche Forum (Escalade EXT)
    Hi guys my 05 Escalade esv 6.0 272,000 miles has alarm level oil pressure at startup for about 2 minutes runs about 40 psi at 2000 rpm and 15 psi at idle after it warms up, sounds ok,no tapping or rattling. 5w30 valvoline syn high mileage.any thoughts ?
  8. Chevy Suburban Forum (GMC Yukon XL)
    Hi all. Been trying to figure out a low oil issue on my brothers 2005 suburban z71 with a 5.3 and 140k on the clock. Idles at about 20 lbs of pressure, maybe a touch lower. Replaced the oil pressure sensor, didn’t help. Did the o ring, also didn’t seem to help but the old o ring was pretty...
1-8 of 8 Results
Top