GM Truck Club Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Hi guys. So i bought a tahoe 2012 5.3 2wd recently and it has ticking noise from under the hood on cold start for about 30 seconds and then when i start accelerating but stops when the car is in motion but even when in motion if i accelerate the noise comes back. Any thoughts?? Just a little...
  2. Chevy Suburban Forum (GMC Yukon XL)
    2015 Yukon XL SLE, 5.3, 6 speed auto with 4WD and tow button, 124K miles. Never heard this noise until today. When driving constant 45 MPH let off the gas then moderate acceleration there is a sound coming from trans. Hard to describe, a groaning squeak, its short and abrupt. No slamming or...
  3. General Chevy & GM Tech Questions
    Hey all, just bought a lovingly used 2003 Yukon Denali with 180k on it. I had two mechanics look it over before sale, and besides some goofy 22” rims and tires which DONT BELONG on that vehicle, it was sound. I just drove it 500 miles through the mountains of Utah down to Phoenix, pretty...
  4. Chevy Avalanche Forum (Escalade EXT)
    Hi everyone. I have a 2008 Avalanch with 6.0 (swapped engine) It’s started making ticking noises, I think the lifters are ticking. What I’ve noticed is the oil pressure starts to drop as long as the engine temperature increases, so I did an oil and filter change immediately. No more noise for...
  5. Chevy Silverado Forum (GMC Sierra)
    Hello I have a 2009 Chevy Silverado with roughly 270,000 on the 4.8 motor.the truck is already In rough shape but the problem I am having with it is when I try to use the AC there are times it works or just makes a noise like it wants to turn on but fails.this happens when I try to use the hot...
1-5 of 5 Results
Top