GM Truck Club Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hi all,
I have a 2000 Silverado LS with 5.3L engine, 4 speed transmission, with 80k on the odometer. I just started noticing it shifts roughly from first to second gear, but only when warm, and only at lower RPMs. If I get on it, it does not shift roughly. It also does not do it when the block is cold. It doesnt clank or anything, but its definitely enough of a rough shift to get my attention, definitely shifts rougher than 2nd to 3rd or 3rd to 4th. It may have been doing this for a while I'm not sure, I just started drving easier to save gas and noticed it. Checked tranny fluid and it is nice and red and at the full mark. Any ideas? I'm just trying to avoid the 'try this, then try that' until its fixed, cause that can get pricey! Would it be the solenoid, or something as simple as a filter/fluid change? I am pretty mechanically inclined so I am able to do a little bit of work myself...anyone have any advice?

Thanks!

-Rob
 

·
Moderator
Joined
·
4,774 Posts
Hi all,
I have a 2000 Silverado LS with 5.3L engine, 4 speed transmission, with 80k on the odometer. I just started noticing it shifts roughly from first to second gear, but only when warm, and only at lower RPMs. If I get on it, it does not shift roughly. It also does not do it when the block is cold. It doesnt clank or anything, but its definitely enough of a rough shift to get my attention, definitely shifts rougher than 2nd to 3rd or 3rd to 4th. It may have been doing this for a while I'm not sure, I just started drving easier to save gas and noticed it. Checked tranny fluid and it is nice and red and at the full mark. Any ideas? I'm just trying to avoid the 'try this, then try that' until its fixed, cause that can get pricey! Would it be the solenoid, or something as simple as a filter/fluid change? I am pretty mechanically inclined so I am able to do a little bit of work myself...anyone have any advice?

Thanks!

-Rob
Rob.....Take a look at the Link below.......it may be able to help,

Link,
http://www.gmtruckclub.com/forum/showthread.php?54475-LOOK-HERE!!!-Trouble-code...p1870.....for-harsh-1-2-shifts.....
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
Sounds like my problem, because my service engine light is on! However, I dont know which code its throwing but it sounds very similar....Anybody know where to get one of these valves/price/install method?

btw, thank you! a lot faster than sorting through all these threads on my own!
 

·
Moderator
Joined
·
4,774 Posts
Sounds like my problem, because my service engine light is on! However, I dont know which code its throwing but it sounds very similar....Anybody know where to get one of these valves/price/install method?

btw, thank you! a lot faster than sorting through all these threads on my own!
A Transmission Shop can do a Scan, and will be able to tell you what Trouble Code is causing your SEL to come.


Edit:.....For Pricing and the Install of the Valve Body, check with your local Transmission Shops.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
Verdict: pressure control valve is bad, needs replaced. Having entire tranny checked while I'm at it. Covered under my extended warranty. AAMCO doing the work. Total cost for the valve replacement is upwards of $500. This will cause tranny failure eventually if left untouched, as transmission pressures are either far too high or far too low (mine is far too high, causing the rough shift).
 

·
Registered
Joined
·
18 Posts
Discussion Starter #6
Just an update for you all/a close to this post...I had tranny rebuilt while I was at it. New PCV, New Solenoid, New HD torque converter, etc. Shifts like a gem now! And warrantied for 30k miles!
 
1 - 6 of 6 Posts
Top