GM Truck Club Forum banner
1 - 20 of 45 Posts

· Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
There's no light beside the Hi and Lo 4x4. Not able to select.

I realized it wasn't working after i replaced the driver side hub and sensor.
I'd also replaced the brake switch not knowing I was driving from Chicago to Des Moines without brake light. I did not replace the cruise swith. Cruise not working but switch tested fine. New switch ordered anyway.
Dealer wants to charge $90 an hour for trouble shoot with 2 hours minimum and not guarantee. Might need more time. $50 machine diagnostic plus 2 hours trouble shoot. That's automatic $230 of not guarantee.
So I like to try and do it myself before the cold.
Where would I started first?

05 Colorado crew cab
 

· Registered
Joined
·
18,106 Posts
When you start the truck, there is a self test for the lights, all of the switch position lights should come on for a couple of seconds.
Do any of them light?
Do you have a rotary switch?
 

· Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
All light are all normal. Not sure about other Colorado but mine is a push button(pictured). 2 - 4H -4L. I'm assuming I'm on 2 wheel drive(rear) right now and the indicator should be lit on the 2H button.
No engine light. Dealer could not find any code.
Maybe one had to work for another to work. Like the cruise control.
 

Attachments

· Registered
Joined
·
18,106 Posts
Ok, no problem. Mine is rotary, just trying to picture yours, thanks for pic.

Ok, your saying the 2Hi, the Neutral, and each of the 4x4 lights will light when the truck is started. They then all go out after a few seconds.
 

· Registered
Joined
·
18,106 Posts
I don't have a Colorado. The switches are different, but they all work the same.

You are frustrating me. Please go back and read my previous post. I can't tell if the 4x4 positions are out and the others work; but then I read where the 2hi doesn't work. I need you to answer the question as it applies to all lights.

I am trying to figure out if you have a light problem, or a circuit problem.

Please answer the question in the previous post.
 

· Registered
Joined
·
16 Posts
Discussion Starter · #8 ·
Ok. All light from front headlight to brake works. All light from dash to dome light works. The only light (indicator) also circled in picture doesn't work. Meaning is not functioning. I don't know how it function. Don't know what can cause it not to function.
 

Attachments

· Registered
Joined
·
16 Posts
Discussion Starter · #11 ·
If it's unplug the 4x4 will engage differently. Like it knows it's unplug. I guess only Colorado owner understand. No offense. I know you guys are trying to help. To get help from none Colorado owner I feel I have to educate on how the Colorado function.
you should be able to gently pry that out of the dash and inspect the plug ect...
 

· Registered
Joined
·
4,270 Posts
well I just read there is a tonne of problems with these trucks and making 4x4 actually work. pull the fuse to reset the tccm (transfer case control module) if this dont work you need a new tccm. apparently there is nothing that can be reprogramed in the tccm they either work or dont. the stealership may be your best bet.

good luck.
 

· Registered
Joined
·
18,106 Posts
If none of the button lights work at any time, and, nothing happens when you push the buttons, then, the switch assembly is unplugged, or you have blown a Transfer Case Control Module fuse.
 

· Registered
Joined
·
16 Posts
Discussion Starter · #14 ·
Thank you? I will check the TCCM. If the TCCM is bad. Wouldn't it show up in their diagnostic report which I paid $50 for and there's isn't any faulty report coming from the 4x4 or related.
 
1 - 20 of 45 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top