GM Truck Club Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I am cruising down the interstate at 70 mph. The engine cuts out for a split second, the doors unlock and lock, the gauges drop and come back. The thing is, once I dropped down to about 50 mph, it was fine. I went up to 70 and it started doing it again. Odd that it's fine around town but when I get on the interstate up to 70 it freaks out.
Dealer has replaced the PCM, the accelerator module and the ignition switch. Also ran all TSB's anout grounds and marginal connections.
Any ideas?
 

·
Registered
Joined
·
147 Posts
You have probably already checked but just in case...

I would remove and carefully inspect both batt. cable terminals.

Bert
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Yes, i forgot to mention, but when I got the truck 2 months ago, the + cable kept comming loose. I bought a new batt and replace both term bolts. Now both stay tight.
thanks!
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Also I failed to mention in my original post that once the truck warms up, it's fine. And it has never done it when the outside temperature is above 40*. Also around town, going under 50mph, over RR tracks, speed bumps, pot holes whatever, it NEVER dies. Only on the highway above 50mph. I step on the pedal and it stalls out. If I hold the pedal at the point where it stalls, it will not increase in speed after the engine recovers it will stay about 50. If I let off the pedal and ease it back down, I can eventually get it back up to 70 or so. Also once it starts messing up, cruise control no longer works. If I pull over, turn off the engine and restart it, cruise will work fine and the truck will work fine from then on out.
 

·
Registered
Joined
·
27 Posts
Fly by Wire throttle??? Double check the connections at the pedal, computer and the throttle body. Sounds suspiciously like a flat spot or open in the TPS or the throttle circuit.
 

·
Registered
Joined
·
4 Posts
if you find out what is wrong with your car let me know my friends 08 Avalanche is having something similar.
But doesn't turn off but everything else do it....


tks
 
1 - 7 of 7 Posts
Top