GM Truck Club Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
New to the forum, not sure if this is already a thread so bare with me. I have an 05 Tahoe Z71 with the 5.3. Bone stock engine, i have an aftermarket exhaust and stock air intake. there is a whine/whistle when i’m around 1900-2200 rpm. i can hear it going down the highway and i can also rev it up and hear it. belt on belt off, intake on, intake off it makes the sound no matter what. really stumped on this. thought it would be a vacuum leak but i’ve sprayed about everything around injectors and throttle body but no change in rpm. can’t seem to find an answer on any other forum so any help will be appreciated
 

·
Registered
Joined
·
16,397 Posts
Ok, I was thinking it might be wind noise.
With the hood up you should be able to follow the sound and get close to the source. But you need an assistant.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
update
i’m pretty sure it’s my intake. when i hit the throttle suddenly, it gives that little gasping sound. everybody with an ls knows the sound i’m talking about, but i can also hear that whistle when i do that. must just be the engine sucking a whole lot of air in during that RPM range. i did notice that one of the tabs to hold the lid of the box is cracked and the threads are kinda stripped on that one and another one. i planned on putting a cold air intake on it so hopefully that solves the sound
 

·
Registered
Joined
·
12 Posts
i’ve tried to track it down it sounds like it’s on the passenger side lower part of the engine
Check the end bolt on the exhaust manifold, very common to find this bolt broken off on the 4.8 and 5.3. I repaired it the hard way by taking the head off and drilling the bolt out, BUT there is a clamp on the market that bolts to the back of the block and uses a third bolt to compress the exhaust manifold.
 

·
Registered
Joined
·
6 Posts
New to the forum, not sure if this is already a thread so bare with me. I have an 05 Tahoe Z71 with the 5.3. Bone stock engine, i have an aftermarket exhaust and stock air intake. there is a whine/whistle when i’m around 1900-2200 rpm. i can hear it going down the highway and i can also rev it up and hear it. belt on belt off, intake on, intake off it makes the sound no matter what. really stumped on this. thought it would be a vacuum leak but i’ve sprayed about everything around injectors and throttle body but no change in rpm. can’t seem to find an answer on any other forum so any help will be appreciated
Keep in mind:
Air blowing/coming out (wherever) generally makes a hissing &/or puffing sound/noise.
Air sucking/coming in (wherever) generally makes a whistling sound/noise.
But judging from your most recent post (that I’ve seen) you have found the vacuum leak.
Where was it?
 
1 - 16 of 16 Posts
Top