GM Truck Club Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have an 07 Sierra classic and the 4wd is not working. I press the auto 4wd, 4wd hi, or 4wd low and the light just flashes. I can hear the transfer case trying to engage. I have verified the ground connection under the driver and have replaced the dash switch. I do get a "Service 4wd" on the alerts but no codes. It worked fine the last time I used it about 6 months ago. I also performed a fluid change on the front and rear Differentials and a fluid change on the transfer case.
 

·
Registered
Joined
·
605 Posts
I would try to put the truck up on 4 jack stands and so that all 4 wheels are off the ground. Have someone start it and put it in 4WD and in drive. Then see if the front driveshaft is turning under power from the transfer case. If it is then it's something to do with the front differential which could be the axle actuator or a component in that front 4WD system. If the front driveshaft isn't turning under power then I would have someone hold one of your front wheels while 4WD is selected and try to turn the other one and see if the front driveshaft spins by doing that. If it does then the front axle is going into 4WD but the transfer case isn't. Make sure you do that part while the transmission is in neutral. This should help you figure out if it's something to do with the transfer case or front axle.
 
  • Like
Reactions: RayVoy

·
Registered
Joined
·
4 Posts
From what i could see, the 07 Sierra is one of the most complained models. Mostly pertaining to issues like 4wd transfer case, sensor switch, and even the HVACs. Preferably, take the truck to nearest dealer.
 
1 - 4 of 4 Posts
Top