GM Truck Club Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 · (Edited)
Hi, i have an 85 astro van, it has a 1989 700r4 trans, and it acts like it's constantly in passing gear, has plenty of low end, but lacks at hiway speeds, and floor it to engage passing gear, and nothing happens. has been this way since the trans was installed. thanks.
 

·
Registered
Joined
·
2,966 Posts
Sounds to me like kick down linkage isn't set up right. If what your saying is it won't pull back passing gear.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
Hmm, i was under the influeance the trans don't use a Per Say, Kick Down Cable, but a Throttle Valve System. I don't know, the trans is out of a 89 Astro. as for the gear selector, i'v checked it, and it's dead on. Sits right on D like it's supposed to. and is exactly 3 clicks from Park.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
Help!!!

I'v exausted all my ideas, anyone know anything about the Throttle Valve systems on an 89 model year 700R4 being bolted to an 85 model year 4.3L 4BBL
 

·
Registered
Joined
·
25 Posts
my own experience

The tv cable controls kickdown and main line pressure.If it is not adjusted correctly it will not let TCC lockup (no OD)!.I know this from expeience ,I accidentally bent the TV cable bracket ,when I torqued the valve body to case ,everything worked exept OD .I had to remove the oil pan several times (not fun)
here is the link on correct TV cable adjustment ,I would start here first. http://www.tvmadeez.com/article/index.html
If that does not fix,I would start checking for constant 12v voltage at the lock up solenoid,pressure check 4rth gear pressure switch and check resistance on ground(controls lock up)side of circuit. check all connections.OH, almost forgot a closed brake switch will not let you go into OD.
Good luck.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #7 ·
Thanks Bobby, Very Good Page Link There. Is Informative, Will be checking that out tomorrow, might be able to keep from installing a new trans in to the van. would be nice, although, i do have a new one now just haven't put it in yet, anyway, will look into that tommorrow, thanks for the link. Your a big help here...
 

·
Registered
Joined
·
25 Posts
more help

check for bad solenoid switch .check for constant 12v at TCC solenoid(red).and pressure check pressure switch you will have to remove (yellow) check all ground connections leading to thermo switch.check your main connection to the case.

but first start by checking TV cable adjustment. good luck
 

Attachments

1 - 8 of 8 Posts
Top