GM Truck Club Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Where to begin... I have replace the front wheel bearings, real axle shafts and bearings, and just rebuilt the transfer case. The reason for the latter was that when I put the truck in 4WHi, the noise stops. This started out very quiet and has continued to get more persistant. Initially you could let up on the gas pedal and it would go quiet. Ready to park this one in a canal, so please help if you have a recommendation. Had the rear end checked and they also checked the pinion bearing.:grrrrrr::grrrrrr:
 

·
Registered
Joined
·
7,979 Posts
Anyone take a look at the front driveshaft U-joints? or the ujoints in general?
 

·
Registered
Joined
·
7,979 Posts
Sounds like it could be a bad powersteering pump or a noisy tranny pump... otherwise if everything else has been checked those are really the only other things.
 

·
Registered
Joined
·
155 Posts
Sounds like you didn't put the 2 wheel high part of the transfer case back together right, prolly the bearing for the syncro or whatever it has, if it goes away in 4 wheel high, but is present in 2 wheel drive, then it has something to do with the 2 wheel high part of your transfer case, which should just be direct drive and bypassing the gear that drives your front axles. I would pull it apart and check all your clearances with a fine tooth comb.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #6
Took to a second shop and found that the ring and pinion were bad. I've got to admit that this truck is frustrating!
 

·
Registered
Joined
·
8,623 Posts
Took to a second shop and found that the ring and pinion were bad. I've got to admit that this truck is frustrating!
Just curious, how many miles on this truck??
 

·
Registered
Joined
·
7,291 Posts
X2 what stephan asked.
 
1 - 9 of 9 Posts
Top