GM Truck Club Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
My 1993 Chevy C1500 loses power when I turn my A/C on when while driving. With the A/C running, the engine seems to idle very rough and will run like crap When I’m on the highway doing 50 or 60 mph
and try to accelerate the engine will begin to bog down and then it will take off. Where should I start looking for the issue. The engine is a 4.3 liter V-6 with TBI.
 

·
Registered
‘01 Silverado 2500HD 8.1/Allison 5sp xcab long bed
Joined
·
3,612 Posts
I’m afraid I don’t have very good news for you, brother. I had the same issue in my 1995. Driving down Main Street at 25 miles an hour and the air conditioner would cut in and it felt like you hit the brakes. It’s especially troubling at highway speed’s when you need a little more horsepower. The 4.3 only has about 165 hp. If you’re up for the challenge, my strong recommendation is a different engine. More specifically, a V-8.

It’s not for the faint of heart, and you will have issues trying to find the proper computer chip because they’re becoming more and more difficult to find. You have to find one from a donor truck with the V8 engine and the same transmission, and that is no small feat.

you will need a new fan shroud, new motor mounts, and of course, the most obvious, the engine.Other members here have more experience with tuning the computer, so you might be able to do a little bit with the 4.3, but don’t expect a lot.
 
  • Like
Reactions: PlaywithTBI

·
Registered
Joined
·
974 Posts
It’s not for the faint of heart, and you will have issues trying to find the proper computer chip because they’re becoming more and more difficult to find.
There are guys over on gearhead-efi.com that can help there. As a matter of fact, @Scuba1x was chatting with @In-Tech there, who mentioned he has some chips he bought years ago and can burn them for your setup, same year maybe same PCM (16147060)? HTH
 

·
Registered
‘01 Silverado 2500HD 8.1/Allison 5sp xcab long bed
Joined
·
3,612 Posts
Jack, what Peter’s talking about here is locating the proper computer chip for your truck if you decide to go with the V8 upgrade. That will be a huge help in making the upgrade almost plug and play.
 
  • Like
Reactions: PlaywithTBI

·
Registered
Joined
·
90 Posts
My 1993 Chevy C1500 loses power when I turn my A/C on when while driving. With the A/C running, the engine seems to idle very rough and will run like crap When I’m on the highway doing 50 or 60 mph
and try to accelerate the engine will begin to bog down and then it will take off. Where should I start looking for the issue. The engine is a 4.3 liter V-6 with TBI.
I don’t have experience with the v6 but would think checking fuel pressure is first thing to verify.
 
1 - 5 of 5 Posts
Top