GM Truck Club Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Does anyone know what might cause my 1993 1500 GMC truck to have a loss of power and also have trouble starting.

It was running just fine and now is hard to start and keep running.

It seems like the engine can not even get up past idle speed. When put in gear it has no power at all and stalls out.

Any help would be great

Thanks
Howard
 

·
Premium Member
Joined
·
4,886 Posts
What can you tell us about the truck? What type of engine? How many miles on it?

There can be any number of issues with the engine. Let's get a little bit more information and we'll take a look.
 

·
Premium Member
Joined
·
1,625 Posts
could be timeing, fuel filter, cloged injectors, cloged air filter,fuel pump, and a half dozen other things.
like steve said a little more info, like mileage, engine, gas, or deisel, when did it start?
 

·
Premium Member
Joined
·
4,886 Posts
Just wondering if Howard was back on the board?
 

·
Premium Member
Joined
·
1,341 Posts
This is a longshot, based on the amount of info you stated about your problem, but mine did that a couple of weeks ago. One of the fuel injectors was not spraying. To check yours, take off the air cleaner lid and start the truck. Look down inside the TBI and make sure both injectors are spraying fuel.
 

·
Premium Member
Joined
·
1,625 Posts
If you have a timing light connect it and point it at the injectors when the truck is running. You should be able to see the injector pattern. It should be a nice uniform pattern. If not run some injector cleaner threw it, I like the Gunk brand but to each his own.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top