GM Truck Club Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
2000 Chevy Silverado 5.3 crank but no start. Had this problem and it was the fuel pump replaced pump and filter was driving fine and then it just wouldn’t turn back on one day. There was no warning signs or anything just quit. Thought maybe it was the fuel pump so I replaced it again (it was under warranty) and the fuel filter still nothing. I’m out of ideas and need help.
 

·
Registered
‘01 Silverado 2500HD 8.1/Allison 5sp xcab long bed
Joined
·
4,002 Posts
Will it start with starting fluid sprayed into the intake?
 
  • Like
Reactions: RayVoy

·
Registered
2001 Suburban 5.3L, 298k miles
Joined
·
1,667 Posts
Fuel tank low or empty?

Test fuel pressure at the rail.
 

·
Registered
2000 Silverado Z71 4x4 5.3L 480k+ miles w/ GM rebuilt motor and trans
Joined
·
1,573 Posts
Sounds like the fuel pump relay is bad. Swap it with the horn relay.
 

·
Registered
Joined
·
6,391 Posts
did you use a pressure gauge ? did you change the new fuel pump ? the OEM 2000 fuel pump is changed the fuel pump electrical connector changes it .. then a mechanic monkey messed up the new wiring on the new connector.. must use soldering and use a heat shrink protection on the wiring change ..
the fuel pressure is 53 psi .. if the pressure drops below 45 psi then the engine stalls ..
another issue the engine starts then the engine stalls .. the CPS is on the flywheel area behind the starter motor. some did have a CPS sensor or the connector on it .

on old vehicles you have to change the fuel pump relay .. the fuel pump motor fails and increases more current and then the old relay should break down and the contacts burn up................
 

·
Registered
Joined
·
7 Posts
2000 Chevy Silverado 5.3 crank but no start. Had this problem and it was the fuel pump replaced pump and filter was driving fine and then it just wouldn’t turn back on one day. There was no warning signs or anything just quit. ...
You need fuel, spark and air (Compression)
Check all three in that order.
It' been 6 days since you posted, so if it was resolved, tell us what it was, ok?
 

·
Registered
Joined
·
1 Posts
2000 Chevy Silverado 5.3 crank but no start. Had this problem and it was the fuel pump replaced pump and filter was driving fine and then it just wouldn’t turn back on one day. There was no warning signs or anything just quit. Thought maybe it was the fuel pump so I replaced it again (it was under warranty) and the fuel filter still nothing. I’m out of ideas and need help.
Try changing the temp sensor that reads to the computer not the one that makes your gauge work. It's up front near the thermostat. My tru ran they would quit when it got hot. I change a bunch of stuff new fuel pump, new filter, the throttle body both sensors on the throttle body! Nothing worked then I looked up what it was doing and it mentioned the temp sensor. So I change that and bam back to running perfect. Been running great since then.its a cheap sensor. I would bet it does the trick!
 

·
Registered
Joined
·
6,391 Posts
Try changing the temp sensor that reads to the computer not the one that makes your gauge work. It's up front near the thermostat. My tru ran they would quit when it got hot. I change a bunch of stuff new fuel pump, new filter, the throttle body both sensors on the throttle body! Nothing worked then I looked up what it was doing and it mentioned the temp sensor. So I change that and bam back to running perfect. Been running great since then.its a cheap sensor. I would bet it does the trick!
your comment ,,,,,,,,,, change the temp sensor .. well the member had NO fuel on the fuel rail !
temp sensor will not stop the fuel pressure pump .
temp sensor fails and the engine starts up then stalls on a cold start ..he had no engine starting no fuel pressure .
 
1 - 13 of 13 Posts
Top