GM Truck Club Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
for the last 3 days my wife says the tahoe has been running rough at times
thinking its bad gas she refueled and last night it wouldnt stay running
unless you lightly pumped peddle .and when you do get it to accelerate
its like half power.all gauge readings are normal.and regular matinence was done.i changed the fuel filter and no difference.its got 80,000 mile and has been serving us well.i do remember awhile ago similar symptom and a neighbor [a diesel mechanic ]fixed something with fuel flow reg. it was small and required a special tool to fix .any advice would be appreciated.
 

·
Registered
Joined
·
36 Posts
for the last 3 days my wife says the tahoe has been running rough at times
thinking its bad gas she refueled and last night it wouldnt stay running
unless you lightly pumped peddle .and when you do get it to accelerate
its like half power.all gauge readings are normal.and regular matinence was done.i changed the fuel filter and no difference.its got 80,000 mile and has been serving us well.i do remember awhile ago similar symptom and a neighbor [a diesel mechanic ]fixed something with fuel flow reg. it was small and required a special tool to fix .any advice would be appreciated.

sounds almost like a vacuum leak but don't take my word on it. try a fuel injector cleaner, and see what happens a good one not any cheap type for a $1. techron is pretty good, duralube, and BG44k is a good one but not cheap.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
sounds almost like a vacuum leak but don't take my word on it. try a fuel injector cleaner, and see what happens a good one not any cheap type for a $1. techron is pretty good, duralube, and BG44k is a good one but not cheap.
ok ill try the cleaner ,see if i could find any vacume leaks .could i do that thing where you spray starting fluid at certain lines to see if engine accelerates.crazy i know ,im just a carpenter trying to save a buck and
only have basic tools ,no vacume gauge heck i dont even have a manual.
got ahold of old neighbor he replaced fuel reg.said impos that its bad again
also said to listen for fuel pump primeing up ,test pressure at rail and it could be map sensor??? what do you think?and where is this sensor at? can i test it
neighbor works nights and i dont want to bug him zzzzzzzzzz.
 

·
Registered
Joined
·
36 Posts
ok ill try the cleaner ,see if i could find any vacume leaks .could i do that thing where you spray starting fluid at certain lines to see if engine accelerates.crazy i know ,im just a carpenter trying to save a buck and
only have basic tools ,no vacume gauge heck i dont even have a manual.
got ahold of old neighbor he replaced fuel reg.said impos that its bad again
also said to listen for fuel pump primeing up ,test pressure at rail and it could be map sensor??? what do you think?and where is this sensor at? can i test it
neighbor works nights and i dont want to bug him zzzzzzzzzz.
When I found my vacuum leak, not my truck with my old car from a long time ago. I could see the leak the hose just wore out and the car could barely stay on at lights, would have to keep my foot on the accelerator.

Recently my mom let her car get real low on gas, and the next day it was hesitating and sputtering, came to find out it was just letting the fuel get low. I put some cleaner in there and that helped it out not doing it anymore I beleive.
Also these trucks can suck some gas in fast so could just be some trash in the system. next chance I get I'm going to buy some bg44k.
 
1 - 4 of 4 Posts
Top