GM Truck Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My 02 Chevy is really giving me some problems. It starts and idles just fine--seems to run fairly well up to about 60mph (if you do not try to take off quickly) but at the slightest upward grade it will shift to a lower gear and rpms try to go from about 1500 up to around 3000+ engine sounds lower & deeper (sort of like a 4bbl carb opening up) but the darn thing
will actually be losing speed. If just let her go with cruise control engaged the engine revs faster and faster and begins to knock and just sounds awful, but if i disengage the cc let the accelerator come up and then ease back down on it very slowly she will once again begin to pick up some speed. i have also noticed that when the automatic transmission goes into the final gear it does not seem to hit it as pronounced as it used to, it seems to sort of just drag in to it with no real definition. (i don't know how else to describe it, hope that's understandable)

Truck Background
2002 Silverado 1500 135,000 miles
Vortec 4300 V6 gasoline
4.3 L

all suggestion are greatly appreciated
Al "Grease Gun" Geno
 

·
Registered
Joined
·
48 Posts
How long has it been since the fuel filter has been changed? I have had a clogged filter rob power under load.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
I have never changed the fuel filter but I will today, I have changed the air filter and went over the engine
several times hoping i would find a vacuum leak. Wires and Plugs i did about 8 mo. ago. i change oil and
filters regularly. i will post results of new fuel filter. thanks
Best Regards
Al
 
1 - 5 of 5 Posts
Top