GM Truck Club Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Ok I have a 2003 Chevy 1500 Z71 Off-road (it has the steering wheel controls.) And I was driving and the air bag light came on and I thought nothin of it then a code in the cluster comes up that says "battery not charging". I turn it off and turn it back on and my batt gauge is all the way down and now its says service 4wd and service brake booster and it says my door is open which it is not and my abs and parking break light come on and I know all of this stuff wouldnt go wrong all at once so is something messed in my computer or? its very frustrating and confusing because sometimes I will be in park and reverse lights are on or the dome light wont shut off inside the cab while driving or the mirrors dim and its dark out. Thanks in advance for any help :)

---------- Post added at 11:12 PM ---------- Previous post was at 11:10 PM ----------

oh and my radio does not turn on. alternator and battery are both good too
 

·
Registered
Joined
·
30 Posts
Discussion Starter #2
well the problem has fixed itself :D
 

·
Registered
Joined
·
806 Posts
It's weird, because I have had my parking light come on out of nowhere, my dome light will sometimes stay on even if the door is shut while the truck is running, and even after I reset my oil life, it will take a day before it finally quits popping up saying "Oil Life Reset". The only complaint I have with these trucks is the computer system in them, and mines the dumbed down work truck model!

Like you, all these problems will fix themselves, but they pop up periodically.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #4
well thats pretty stupid I agree on with you on the computer systems
 
1 - 4 of 4 Posts
Top