GM Truck Club Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I just moved to NY from TX. Yeah, I know! Why?? work. I had used my Z71 suburban on the beaches of the Texas coast about twice a year and now I use it weekly here in up state NY. Last week we began to notice that the 4X4 would not smoothly switch over from 2 wheel drive when needed. When we attempted to go 4x4 the light on 4x4 would blink for a long time. Sometimes I would stop put it in neutral and then it switch to 4x4 more easily. But once in 4x4 it would make some awlful noises from the front end. It would sound like metal grinding. Of course we only used it to get up our drive and into the garage. Otherwise I restricted the use of it. Today, 2/11/08, I drove it to the dealership, because I know of no place else to take to here yet, and while en route, I went to stop at a red light and it seamed that the front end was jerking as if it had really bad brake pads that were warped. But this is the first sign of this issue so I am sure it is not the brakes. Well it is now at the dealership, I am over the 36,000 mile warranty (about 50,000m) and I am hoping someone can spot my issue and give me an idea as to what the dealership should tell me the problem is. When I explained the issue to the service manager he said it sounds like your drive line. I know nothing about the drive line other than what I read on line about the u joints and the angle of the drive shaft. To me it sounds like my front axel, when engaged , is shredding apart. Thanks.
 
1 - 1 of 1 Posts
Top