GM Truck Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a problem with the shift lock not working at times. The dealer replaced the shifter assembly but problem still happens. The problem happens from any time, it seams to happen more if on a slight slope or shortly after going over a driveway entrance and then parking and when I return I cannot get the shifter out of park and I hear no click from the shifter area when I step on the brake. The dealer has checked out the system one time since they replaced the shifter assemble. since I got the TB back from the last time the problem has happend 5 times in the last two weeks. Has any one else had this problem and if so has it been repaired?
 

·
Premium Member
Joined
·
4,886 Posts
From what I remember, this was a problem with the 2002 model. Except that problem would lock up so the shift-lock would not release. Sounds like you've got the opposite problem. I've not heard of anyone else having this issue with the 2005.

Anyone?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for the reply Steve. The problem is that the shift lock will not release from time to time. Then it will just start working normally, some times after restarting the TB or opening and closing a door will get it working again. I feel it is a electrical problem. The dealer told me that there have only been two complants of this kind world wide.

Bruce M
Phoennix AZ
2005 Chevy Trailblazer LS
 

·
Premium Member
Joined
·
4,886 Posts
Ok, I got it wrong. (must have been tired when I read your post the first time).

On the 2002 model, there was a problem with the shift-lock that was recalled. But, I'm not aware of any for the 2005. I doubt that the dealer would know the world-wide count of complaints, that would be impossible to track each and every complaint that only had one complaintant.

I'll see what I can come up with.
 

·
Premium Member
Joined
·
4,886 Posts
Chevy Trailblazer stuck in park

I started having this problem myself over the past two weeks. We almost got stuck at Walmart last night because I couldn't get it out of park.

It's probably a bad ignition switch, that's about $25-30 and I'll fix it myself in no time. It could be a loose lead from the brake pedal that says that the pedal is pressed down. It could be something from the shifter knob that says that it is in park. Or it could be the ignition switch that says the key is installed.

The concept is pretty simple, those three pieces work in conjunction to make certain that the vehicle doesn't move out of park when the brake is not pressed down or the key is not in the ignition. Personally, I liked the old days where you could move cars around w/o a key, but that's not on the topic.
 
1 - 5 of 5 Posts
Top