GM Truck Club Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello everyone,

I purchased a 2005 Trailblazer EXT LS 4x4 in December of 2005. This is my first new vehicle ever. I have been noticing problems with my truck. It may be the way the truck is made to be, but I have a feeling that the following are problems. I took the truck to the dealer and the dealers weren't patient to help and were rude about my problems. I was wondering if anyone has been experiencing the same problems? Please help me out. Here is my list:

1. Rust spots on the vehicle on the doors. Haven't had this vehilce for 5 months and there is rust.

2. The heater/AC doesn't blow out forcefully at settings 1 or 2. I can't feel the heater/AC on the lower level by the feet.

3. RPM's are at 1600 when started them comes down gradually after 1 minute.

4. When stopping for a light or letting off the gas (coasting), the RPM's jump.

5. When stopping for a light or letting off the gas, then accelerating, there is a clunk noise and it is felt.

6. When coming to a complete stop for a light, the RPM's jump while the truck jolts/shifts twice. RPM's jump about 1000.

7. When turning on the AC or heat, there is a noise under the hood soudnding like there is a loose metal fan. Vibration is felt also.

8. When driving, truck pulls to the left. When driving at highway speeds, the truck is difficult to steer straight.

9. When starting the vehicle, the RPM'S & speedometer needles drop downward and shoots back upward.

10. Stopping distance is too long.

11. Turning the steering wheel left to right while at a stop light or in park, RPM's jump.

12. When vehicle is turned on and off, there is rough sound with vibrations.

13. Acceleration from a stop, RPM's go to 6000 or 7000 RPM's, is this normal?

14. When turning with foot off gas or letting foot of gas to coast, then accelerating, there is a big clunk that is felt. Feels like the gears don't shift til the gas pedal is pressed.

15. I noticed taht in the cold mornings that there is a noise coming from the dashboard or under the hood. When driving to a stop sign and completly stopping, there is a sound. The sounds is something loose rolling in the dashboard or under the hood. Sounds like a nut or bolt. I won't hear it if I do that again a few seconds later. It happens everytime in the mornings once, not twice.

These problems have been eating me alive and gets on my nerves... Thank you for your time and consideration.
 

·
Premium Member
Joined
·
4,886 Posts
Wow, that's quite a list. Let me take a look at it. Keep in mind that about 1 in every couple thousand units produced by EVERY manufacturer is a lemon. I knew a guy who's Toyota Corolla engine and tranny went out after 20,000 miles of easy driving. Just had some defects from the plant.

If you have documented these concerns accurately and have not receivied satisfaction from your dealer, tell them that you plan on contacting a lemon law attorney in your state. That should get you bumped up to a GM contact.

Note: Before you do anything, read the first number on your VIN. What is it?

1) Rust spots - There should be no rust at all on the vehicle this new.

2) The heater/AC should blow hard enough and loud enough on the highest setting that you will have a hard time having a low-level conversation with someone in the back seat.

3) This is fairly normal. My 2002 goes to about 1100 for about a minute when cold. The engine is getting warmed up and there is a fairly complex redistribution of exhaust gasses that are warmer coming back into the engine to help get things moving faster. 1600 is a bit high though. Might be a faulty tach.

4) Again, could be a faulty tach. I've driving TBs and an '05 Envoy and had no such issues.

5) Clunk noises are very bad. Even if you punch the accellerator it should never clunk. Could be a faulty U joint or something in the driviline or even worse something in the tranny.

6) If the truck just did this once or maybe a few times it could be bad gasoline, water in the tank, etc. But if it does it frequently, then there is some other issue. Possibly some bad computer components in your vehicle that are causing all of these issues.

7) AC/Heater blower should make a dcent WHOOSH sound. No vibration or metalic sounds should be heard at idle or high speeds.

8) Alignment is a hard issue to get fixed under warranty, becuase you could have ran the thing into a major pothole or into a curb or something.

9) Again, could be a bad comptuer component or a bad tach.

10) I think the 2005 has some computer controlled braking functions (not sure on the TB) and if you're having some other issues that *could* be issues with computer controls, this might make sense. The TB is a decent-sized vehicle and I can't stop in it like I can in my wife's little Caviliar, it's like double the distance. (But it's 40% more weight and double the horsepower, etc.)

11) same issue, tach or computer component.

12) The 4.2L inline six is just about the quietest engine that I have EVER owned. They had to put in the starter kill feature becuase their own engineers didn't know it was running and they would try to start it when it was already running. Again, could be a component issue.

13) same issue

14) again, never should you hear a clunk. Just a smooth ride all the time

15) Again, smooth and quiet ride ALL the time.
 

·
Premium Member
Joined
·
4,886 Posts
Because this is a 2005, you might want to go to a different dealership and test drive a vehicle similarly equipt. See if you experience some of the same issues with braking, etc.
 

·
Registered
Joined
·
404 Posts
WOW, looks like a lemon. Steve's right about having a bad car every now and again. 99.8 of cars are good, but 2 out of 1000 (give or take one) are lemons. You shouldn't have anything but a smooth and enjoyable ride.

Looking over your list, it DOES look like a bad onboard computer could cause all of your problems. Then it would be a cherry ride with just one bad component. I dunnno, anyone else have any suggestions?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
aeropagus said:
WOW, looks like a lemon.
Steve and John,

I want to thank you for your replies and cooperation. Your suggestions are very helpful and I will follow them. Again, thank you both.

The dealers can be sticklers about helping their customers out. Not saying all are bad, but some are.... I don't believe anyone should put up with such unethical and uncalled behavior.

My first number on my VIN is VIN is 1.

2005 TBTB
 

·
Premium Member
Joined
·
4,886 Posts
I hope that you can get this resolved? How does your experience fit in light of my suggestions?
 

·
Registered
Joined
·
18 Posts
wow man! have the dealer fixed anything! i got a 05 envoy nice color in mat-red. driving it home from the dealer as proud as i were in getting a GNC a lady stop me to tell me that black smoke was coming from under the suv. i did not think to much about it thinking it was the new under-coating the dealer just added on, well to make a long story short as soon as i got off the high-way it went dead. good thing for the onstar! when i got back to the dealer i was told the engine blow a piston. i had to pick another envoy but they did not have a red one had to go for the white one and i had to pay 1000 more because it was a 4x4. the dealer was nice and gave me the under-coating, paint and fabric protec- for 5 yrs free. this one has not givin me any problems i am happy with it.
 

·
Premium Member
Joined
·
4,886 Posts
What year TB do you have?
 

·
Registered
Joined
·
6 Posts
I have a 04 TB and I get the engine hesitation with the tach jump sometimes. Also, when the blower is on I get noise from under the hood. No rust though. I have at least a year to go before I can turn in the 04 for a TB SS. I will ride these minor problems out until then.
 
1 - 10 of 10 Posts
Top