GM Truck Club Forum banner

1 - 20 of 33 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Have checked all fuses and swapped the relays under hood. Also checked for any codes. Is it possible that the blower relay also controls the blower for heat, air cond and the rear window wire defrost? I started the truck yesterday and turned on to defrost and nothing. Like there is no power at all to the dash controls for these things. All fuses are good even at the dashboard. I hadn't driven the truck in a week but I seem to remember a smell of burning but it was short and gone. If it's the relay that fried, would this also eliminate power to the rear window defrost? Thanks in advance for any help. Joe.
 

·
Registered
Joined
·
14,498 Posts
The fan in the heat/ac box is separate from the rear window defroster.

Do you have any lights on the dash control unit?
If you push ac, does the ac light come on?
If you push the rear window defogger does the light come on?
 

·
Registered
Joined
·
21 Posts
Discussion Starter #5
I just started to take out the blower resistor but I really didn't think it was going to be the problem. I checked all fuses. Not exactly sure in the hood fuse box if there is a relay there. I did swap the ones I could to see if any thing changed.
 

·
Registered
Joined
·
14,498 Posts
Ok, your on the right track then, suspecting no power.
Would the fuses be in the dash fuse panel?

EDIT:
The blower relay is in the speed control assembly at the blower motor.

There may be a rear defroster relay, or it may be in the Body control Module like the newer trucks.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #8
I've checked all the fuses even the dash ones. Do you think it could possibly be the blower relay? I have one screw to get out to remove it and it's a pain. I've already ordered a new one and its ready for
 

·
Registered
Joined
·
21 Posts
Discussion Starter #9
So. Saying it could be the BCM? Thats a major cost. I also disconnected the battery to see if it was a computer controlled issue. No luck. Frustrating.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #10
There are other issues with the truck. Things that don't work any more: electric door locks, only passengers side window works. I've replaced those door switches in the drivers door. Worked for awhile. Heated mirrors don't work. All I believe controlled by the BCM?
 

·
Registered
Joined
·
21 Posts
Discussion Starter #11
Something odd. With the blower resistor unplugged the dash module lights. The air cond would lite. The rear defogger lit but when I pushed that button, the air circulate button light flashed 3 times and now all are out again.
 

·
Registered
Joined
·
14,498 Posts
The relay in the resistor unit will not effect the lights in that dash unit.

You do not have a BCM problem, you have a power problem

What condition is the underhood fuse panel, is it dirty and corroded?
 

·
Registered
Joined
·
21 Posts
Discussion Starter #13
Something odd. With the blower resistor unplugged the dash module lights. The air cond would lite. The rear defogger lit but when I pushed that button, the air circulate button light flashed 3 times and now all are out again.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #14
As I pulled fuses today I did see some white corrosion is some fuse locations. I knocked off all I could. But didn't know how to really clean the small areas. Wire brush won't do. I have electronic cleaner in a spray can. Cannot use that? The corrosion actually looked like what occurs on battery terminals. Some of the fuses had corrosion also.
 

·
Registered
Joined
·
14,498 Posts
On the next gen of trucks (2008 to 2013) the fuses boxes caused a lot of power problems.
The cure was to replace them.
 

·
Registered
Joined
·
14,498 Posts
Its a 2007 new body style.not s 2008.
You've said that, all I'm saying is that is a common problem with those trucks, perhaps you have a similar problem.

I'm not there to test it, can only offer possibilities
 

·
Registered
Joined
·
21 Posts
Discussion Starter #19
Thanks. I cleaned all fuse blocks today. I replaced every fuse with new ones. The dash unit lights then flashes a few times then lights out. Turn off engine and start again and same issue. I also checked all wiring from the battery
 

·
Registered
Joined
·
14,498 Posts
It isn't just where the fuses plug in, check the connection under and inside the box as well.
 
1 - 20 of 33 Posts
Top