GM Truck Club Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
5.3 V8 with 6-speed auto, 3.42 locking differential, towing package - 4500 miles on odometer.

When coasting to slow down and then hitting the gas to speed up, there is a consistent 1 to 2 second delay before the engine responds and finally goes. This is annoying and not like my 2003 Silverado that responded nearly instantly, like a fuel injected engine was intended to.

Took it to the dealer twice and they did the usual computer checks, etc. with no faults. Service manager said "this is normal, my Silverado does the exact same thing". Guess I'll rethink buying a Chevy next time.

Does anyone have a similar issue and any suggestions for fixing it? Aftermarket chips?

Thanks.
Bruce.
 

·
Registered
Joined
·
7,291 Posts
Welcome to the club, Bruce. Its in the computer, a combination of fly-by-wire throttle and traction control. Most of the aftermarket tuners are working on it. Hang in there.
 

·
Registered
Joined
·
2 Posts
That hesitation can be removed. I have a 2007 with the 6.0. I recently got a black bear tune. The hesitation was removed, the speed limiter was removed. The truck really performs better and without 8.9 or 9.1 gas. I went with the 8.7 octane tune. The live tune ($250) was great.
 

·
Registered
Joined
·
17 Posts
5.3 V8 with 6-speed auto, 3.42 locking differential, towing package - 4500 miles on odometer.

When coasting to slow down and then hitting the gas to speed up, there is a consistent 1 to 2 second delay before the engine responds and finally goes. This is annoying and not like my 2003 Silverado that responded nearly instantly, like a fuel injected engine was intended to.

Took it to the dealer twice and they did the usual computer checks, etc. with no faults. Service manager said "this is normal, my Silverado does the exact same thing". Guess I'll rethink buying a Chevy next time.

Does anyone have a similar issue and any suggestions for fixing it? Aftermarket chips?

Thanks.
Bruce.
Hello,

I have the same issue with my truck. It's a 2010 Silverado Z-71 LT Crew Cab with the apperance package, 5.3L engine. It only hesitates when it's warm, after take off from a stop. It's driving me crazy lol. I thought it was bad gas or something.

My truck has close to 45K miles, it's been great but I would like to know what others are doing to fix the issue, and even gain more performance.Th

Thank you
 

·
Registered
Joined
·
727 Posts
Sounds like its the AFM acting up again...slowing down it usually goes to V4 and once you punch the gas a "slight" hesitation will follow...thats why i disabled it!...feels like a "normal" truck now
 

·
Registered
Joined
·
17 Posts
Sounds like its the AFM acting up again...slowing down it usually goes to V4 and once you punch the gas a "slight" hesitation will follow...thats why i disabled it!...feels like a "normal" truck now
How do you disable the active fuel management?
 

·
Registered
Joined
·
727 Posts
I disabled it using a Diablo Sport Predator..."most" programmers should have that
 

·
Registered
Joined
·
727 Posts
Thats why were here!:great:
 

·
Registered
Joined
·
17 Posts
There is a local performance shop who does HP Tuner. Is this a good tuner? Does anyone have experience using this particular product?

Thanks
 

·
Registered
Joined
·
727 Posts
Ive never had any experience with them
 

·
Registered
Joined
·
17 Posts
Well I decided to go with the Diablo Sport Predator. I'm hoping it will make a difference in eliminating the hesitation, and see an increase in power/torque.

Thank you everyone for all your help.
 

·
Registered
Joined
·
17 Posts
I just installed the 87 Octane tune from the Diablo Sport Predator. The afm still seems to be enabled and it doesn't seem to add more power, but I notice the shift points seem to be a little firmer.
 

·
Registered
Joined
·
17 Posts
So in my opinion, the Diablo Sport Predator tuner didn't work as I expected it to. So with that being said, I returned it. My hesitation is still there, and I didn't feel any power difference with it.
 

·
Registered
Joined
·
727 Posts
Did you actually disable the "DoD"? aka AFM??
 
1 - 17 of 17 Posts
Top