GM Truck Club Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2015 Silverado High Country with a 5.3. Truck has 49,000 miles. I have been experiencing what I believe to be some transmission issues. It commonly shifts very hard into drive and reverse from the parked position. There is also a strange humming noise when doing about 55. I have also noticed that the truck shifts very hard from 1 to 2 and I also notice some significant rpm jumps while driving at a steady speed. Lastly, it seems to hesitate when leaving a stopped position and accelerating. I did bring the vehicle in and was told everything checked out with the transmission. I did read there was some sort of recall a while back relating to the transmission fluid needing to be flushed and changed. We had similar issues with my wife's GMC Acadia and it ended up being a bad torque converter(although the issue hasn't been completely resolved).

I have also noticed while idling, the truck seems to have a pretty decent "shake".
 

·
Registered
Joined
·
16,239 Posts
Ben, is it a 6 speed, or the 8 speed transmission?
Do you have any service messages on the dash?
Is the yellow Check Engine Light on?
 

·
Registered
Joined
·
16,239 Posts
Ok, it's the 8 speed that has most of the problems.
However, the 2014 and up 6 speeds do experience some problems.
Do a little research an the Dexron 6 fluids and have your transmission flushed with the newest recommendation.
 

·
Registered
Joined
·
6,299 Posts
MANY HAVE GM TRANSMISSION ISSUES ..NEW GM !
You have to change the fluid and filter ... the transmissions shift alot to increase gas mileage ...
probably flush out all that fluid from the factory ..
dirty fluid will cause a torque converter ,,..
 

·
Registered
Joined
·
6,299 Posts
MANY HAVE GM TRANSMISSION ISSUES ..NEW GM !
You have to change the fluid and filter ... the transmissions shift alot to increase gas mileage ...
probably flush out all that fluid from the factory ..
dirty fluid will cause a torque converter ,,..
on my 1996 IMPALA I replaced the tranny fluid at 20K miles .... that factory fluid looked like crap .. the pan was a mess.. I changed the Dexron III to mobil syn transmission fluid dex/merc .. my Impala works great and I changed my fluid and it looks like new ...no pan crap in the pan !
 

·
Registered
Joined
·
13 Posts
I have also noticed that the truck shifts very hard from 1 to 2 and I also notice some significant rpm jumps while driving at a steady speed. Lastly, it seems to hesitate when leaving a stopped position and accelerating. I did bring the vehicle in and was told everything checked out with the transmission. I did read there was some sort of recall a while back relating to the transmission fluid needing to be flushed and changed. We had similar issues with my wife's GMC Acadia and it ended up being a bad torque converter(although the issue hasn't been completely resolved).

I have also noticed while idling, the truck seems to have a pretty decent "shake".
Hi Ben - I have a 2018 5.3 LTZ with similar (but more mild) conditions that you express. I also have the 6-speed trans.
I don't have the shake that you mention. I've deleted AFM because I hate the 8cyl to 4cyl drops, but I haven't driven it enough yet since then to determine if that is helpful.

Anyway, as I was doing research on the transmission issue, I found this link: TCC Shudder and New Mobil 1 Fluid Exchange – TechLink
which you should read through. As best as I can tell, it is mostly the 8-speed transmissions experiencing the issues, including the TCC shudder. Changing over to the newer trans fluid looks like it solves a fair amount of issues on that trans. But as I read through all of those notes in that post, I don't see where it recommends that newer fluid for the 6-speed trans though.
 
1 - 7 of 7 Posts
Top