GM Truck Club Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hey all im new to the Chevy world and just bought this truck.

Im having some problems with my headlights not coming on.
i have read a few other threads related to this problem but where others have has success i have not.

So when i pull out the headlight switch all of the lights on the truck come on except for the headlights, like in other threads i replaced the switch and fuses but i still have no headlights.
i have checked the grounds and everything i can see.
Are there any other areas i should check. the firewall where the wires come though seem to be fine, im at a loss.
any help?
Thanks
 

·
Registered
Joined
·
293 Posts
You say you replaced the switch... Did you replace the one you pull to turn the headlights on, or the high/low beam switch? If memory serves that year will have a floor mount high/low switch, and when those go bad you can lose all headlights. Use your test light, check power going to that switch. if you have power to it when your main switch (to turn them on) is pulled out, then it's probably the high/low switch.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
You say you replaced the switch... Did you replace the one you pull to turn the headlights on, or the high/low beam switch? If memory serves that year will have a floor mount high/low switch, and when those go bad you can lose all headlights. Use your test light, check power going to that switch. if you have power to it when your main switch (to turn them on) is pulled out, then it's probably the high/low switch.
I think you are on the right path. i was just talking with a friend about it and he said the same thing.
It did not even cross my mind for some reason to check the high/low switch.
ill give it a check tonight.
thanks for the tip.
 

·
Registered
Joined
·
878 Posts
X2 on the hi/lo. Did you also pull the plugs from the headlights to check for power and wire breaks?

Good luck,
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
X2 on the hi/lo. Did you also pull the plugs from the headlights to check for power and wire breaks?

Good luck,
Yes, and i was getting no power, apparently if the high/low beam switch is jammed there will be no power to the headlights. im pretty confident this is the problem. if not i will be at a total loss and new wires will be flying.
thanks for the ideas its a huge help.

---------- Post added at 11:30 AM ---------- Previous post was at 10:51 AM ----------

Success! got a new High/low Beam Switch.
Ran home, i can understand why it was bad. i had a hard time getting the connector off from corrosion, mud, dirt.
got it cleaned up and Ha HA i have lights.
Thanks guys!
 

·
Registered
Joined
·
878 Posts
Congrats..
 

·
Registered
Joined
·
293 Posts
yeah they tend to jam/freeze up after 5-10 years. thankfully they're dirt cheap and easy to replace!
 
1 - 7 of 7 Posts
Top